<!DOCTYPE html>
<!--[if lt IE 7]>      <html class="lt-ie9 lt-ie8 lt-ie7" lang="en-US" prefix="og: http://ogp.me/ns#"> <![endif]-->
<!--[if IE 7]>         <html class="lt-ie9 lt-ie8" lang="en-US" prefix="og: http://ogp.me/ns#"> <![endif]-->
<!--[if IE 8]>         <html class="lt-ie9" lang="en-US" prefix="og: http://ogp.me/ns#"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US" prefix="og: http://ogp.me/ns#"> <!--<![endif]-->
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="http://gmpg.org/xfn/11">
<link rel="pingback" href="https://www.diabetesselfmanagement.com/xmlrpc.php">
<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-5877cba327754b5f"></script> 
<title>Butternut Squash and Millet Soup - Diabetes Self-Management</title>

<!-- This site is optimized with the Yoast SEO Premium plugin v5.6.1 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="Looking for a soup to warm you up this autumn? You&#039;ll love our flavorful Butternut and Millet soup! Visit DiabetesSelfManagement.com for the recipe."/>
<link rel="canonical" href="https://www.diabetesselfmanagement.com/recipes/soups-stews/butternut-squash-millet-soup/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Butternut Squash and Millet Soup - Diabetes Self-Management" />
<meta property="og:description" content="Looking for a soup to warm you up this autumn? You&#039;ll love our flavorful Butternut and Millet soup! Visit DiabetesSelfManagement.com for the recipe." />
<meta property="og:url" content="https://www.diabetesselfmanagement.com/recipes/soups-stews/butternut-squash-millet-soup/" />
<meta property="og:site_name" content="Diabetes Self-Management" />
<meta property="og:image" content="https://cdn.diabetesselfmanagement.com/2017/10/Butternut-Squash-and-Millet-Soup.jpg" />
<meta property="og:image:secure_url" content="https://cdn.diabetesselfmanagement.com/2017/10/Butternut-Squash-and-Millet-Soup.jpg" />
<meta property="og:image:width" content="800" />
<meta property="og:image:height" content="450" />
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","@id":"#website","url":"https:\/\/www.diabetesselfmanagement.com\/","name":"Diabetes Self-Management","potentialAction":{"@type":"SearchAction","target":"https:\/\/www.diabetesselfmanagement.com\/?s={search_term_string}","query-input":"required name=search_term_string"}}</script>
<!-- / Yoast SEO Premium plugin. -->

<link rel='dns-prefetch' href='//widgets.getsitecontrol.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Diabetes Self-Management &raquo; Feed" href="https://www.diabetesselfmanagement.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Diabetes Self-Management &raquo; Comments Feed" href="https://www.diabetesselfmanagement.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Diabetes Self-Management &raquo; Butternut Squash and Millet Soup Comments Feed" href="https://www.diabetesselfmanagement.com/recipes/soups-stews/butternut-squash-millet-soup/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.diabetesselfmanagement.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=e80099dd32ec93390998d532cb3193c7"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b!==c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='taxonomy-image-plugin-public-css'  href='https://www.diabetesselfmanagement.com/wp-content/plugins/taxonomy-images/css/style.css?ver=0.9.6' type='text/css' media='screen' />
<link rel='stylesheet' id='diabetesselfmanagement-style-css'  href='https://www.diabetesselfmanagement.com/wp-content/themes/diabetesselfmanagement/style.css?ver=1507132025' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-css'  href='https://fonts.googleapis.com/css?family=Open+Sans:400italic,600italic,700italic,400,600,700&#038;subset=latin,latin-ext' type='text/css' media='all' />
<!--[if lt IE 9]>
<link rel='stylesheet' id='diabetesselfmanagement-ie-css'  href='https://www.diabetesselfmanagement.com/wp-content/themes/diabetesselfmanagement/css/ie.css?ver=20141205' type='text/css' media='all' />
<![endif]-->
<script type='text/javascript' src='https://www.diabetesselfmanagement.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://www.diabetesselfmanagement.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<link rel='https://api.w.org/' href='https://www.diabetesselfmanagement.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.diabetesselfmanagement.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.diabetesselfmanagement.com/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='https://www.diabetesselfmanagement.com/?p=30219' />
<link rel="alternate" type="application/json+oembed" href="https://www.diabetesselfmanagement.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.diabetesselfmanagement.com%2Frecipes%2Fsoups-stews%2Fbutternut-squash-millet-soup%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.diabetesselfmanagement.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.diabetesselfmanagement.com%2Frecipes%2Fsoups-stews%2Fbutternut-squash-millet-soup%2F&#038;format=xml" />
<script type='text/javascript'>
(function() {
var useSSL = 'https:' == document.location.protocol;
var src = (useSSL ? 'https:' : 'http:') +
'//www.googletagservices.com/tag/js/gpt.js';
document.write('<scr' + 'ipt src="' + src + '"></scr' + 'ipt>');
})();
</script>
<script type='text/javascript'>
googletag.defineSlot('/8842/DSM/recipes/soups-stews', [[970,250], [970,90], [728, 90]], 'div-ad-leaderboarda').addService(googletag.pubads());
googletag.defineSlot('/8842/DSM/recipes/soups-stews', [300, 250], 'div-ad-boxa').addService(googletag.pubads());
googletag.defineSlot('/8842/DSM/recipes/soups-stews', [300, 251], 'div-ad-boxb').addService(googletag.pubads());
googletag.defineSlot('/8842/DSM/recipes/soups-stews', [160, 600], 'div-ad-skyscrapera').addService(googletag.pubads());
googletag.defineSlot('/8842/DSM/recipes/soups-stews', [2, 2], 'div-nextmillenium').addService(googletag.pubads()).setTargeting('pos','nextmillenium');
googletag.pubads().setTargeting('Device','Desktop');
googletag.pubads().setTargeting('A',['Jenny Craig','Trulicity']);
googletag.pubads().setTargeting('T',['/recipes/soups-stews/butternut-squash-millet-soup/','/recipes/soups-stews/butternut-squash-millet-soup']);
googletag.pubads().enableSyncRendering();
googletag.pubads().enableSingleRequest();
googletag.enableServices();
</script>
<link rel="amphtml" href="https://www.diabetesselfmanagement.com/recipes/soups-stews/butternut-squash-millet-soup/amp/" /><!--[if lt IE 9]>
<script src="//html5shiv.googlecode.com/svn/trunk/html5.js"></script>
<![endif]-->
</head>

<body class="recipe-template-default single single-recipe postid-30219 desktop">
<!-- Google Tag Manager -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-MNZRRD"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-MNZRRD');</script>
<!-- End Google Tag Manager -->
<div id="page" class="hfeed site">
	<a class="skip-link screen-reader-text" href="#content">Skip to content</a>
		<header id="masthead" class="site-header" role="banner" style="margin-bottom: 0;">
		<div class="wrapper">
			<div class="site-header__branding">
								<div class="site-header__site-title"><a href="https://www.diabetesselfmanagement.com/" rel="home"><img alt="Diabetes Self-Management" src="https://www.diabetesselfmanagement.com/wp-content/themes/diabetesselfmanagement/images/logo2x.png" title="Diabetes Self-Management" width="270" /></a></div>
			</div><!-- .site-branding -->
	
			<div class="site-header__utility">
				<div class="site-header__social">
					<ul class="social-nav">
		<li class="social-nav__item social-nav__facebook"><a class="icon icon-facebook-circled" href="https://www.facebook.com/DiabetesSelfManagement" target="_blank"><span class="screen-reader-text">Facebook</span></a></li>
			<li class="social-nav__item social-nav__twitter"><a class="icon icon-twitter-circled" href="https://twitter.com/ManageDiabetes" target="_blank"><span class="screen-reader-text">Twitter</span></a></li>
			<li class="social-nav__item social-nav__pinterest"><a class="icon icon-pinterest" href="https://www.pinterest.com/diabetesrecipes/" target="_blank"><span class="screen-reader-text">Pinterest</span></a></li>
		</ul>				</div>
				<div class="site-header__mobile-controls" id="mobile-toggles">
					<button class="btn-alt toggler search-toggle" id="search-toggle" aria-controls="search" aria-expanded="false"><i class="icon-search"></i><span class="screen-reader-text">Search</span></button>
					<button class="btn-alt toggler menu-toggle" id="menu-toggle" aria-controls="menu" aria-expanded="false"><i class="icon-menu"></i><span class="screen-reader-text">Menu</span></button>
				</div>
				<div class="site-header__search" id="site-search">
					<form role="search" method="get" class="search-form" action="https://www.diabetesselfmanagement.com/" id="search-form">
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input type="search" class="search-field" placeholder="SEARCH" value="" name="s" title="Search for:" />
	</label>
	<input type="submit" class="search-submit" value="GO" />
	<span class="searchbox-icon"></span>
</form>				</div>
			</div>
		</div>
		<nav id="site-navigation" class="site-header__main-navigation" role="navigation">
			<div class="menu-primary-container"><ul id="menu-primary" class="menu"><li id="menu-item-127" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-127"><a href="http://www.diabetesselfmanagement.com/about-diabetes/">About Diabetes</a>
<ul  class="sub-menu">
	<li id="menu-item-122" class="menu-item menu-item-type-taxonomy menu-item-object-about_diabetes_cat menu-item-122"><a href="https://www.diabetesselfmanagement.com/about-diabetes/types-of-diabetes/">Types of Diabetes</a></li>
	<li id="menu-item-119" class="menu-item menu-item-type-taxonomy menu-item-object-about_diabetes_cat menu-item-119"><a href="https://www.diabetesselfmanagement.com/about-diabetes/diabetes-basics/">Diabetes Basics</a></li>
	<li id="menu-item-121" class="menu-item menu-item-type-taxonomy menu-item-object-about_diabetes_cat menu-item-121"><a href="https://www.diabetesselfmanagement.com/about-diabetes/kids-diabetes/">Kids &#038; Diabetes</a></li>
	<li id="menu-item-120" class="menu-item menu-item-type-taxonomy menu-item-object-about_diabetes_cat menu-item-120"><a href="https://www.diabetesselfmanagement.com/about-diabetes/general-diabetes-information/">General Diabetes Information</a></li>
</ul>
</li>
<li id="menu-item-128" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-128"><a href="http://www.diabetesselfmanagement.com/managing-diabetes/">Managing Diabetes</a>
<ul  class="sub-menu">
	<li id="menu-item-109" class="menu-item menu-item-type-taxonomy menu-item-object-managing_diabetes_cat menu-item-109"><a href="https://www.diabetesselfmanagement.com/managing-diabetes/blood-glucose-management/">Blood Glucose Management</a></li>
	<li id="menu-item-114" class="menu-item menu-item-type-taxonomy menu-item-object-managing_diabetes_cat menu-item-114"><a href="https://www.diabetesselfmanagement.com/managing-diabetes/treatment-approaches/">Treatment Approaches</a></li>
	<li id="menu-item-110" class="menu-item menu-item-type-taxonomy menu-item-object-managing_diabetes_cat menu-item-110"><a href="https://www.diabetesselfmanagement.com/managing-diabetes/complications-prevention/">Complications &#038; Prevention</a></li>
	<li id="menu-item-115" class="menu-item menu-item-type-taxonomy menu-item-object-managing_diabetes_cat menu-item-115"><a href="https://www.diabetesselfmanagement.com/managing-diabetes/womens-health/">Women&#8217;s Health</a></li>
	<li id="menu-item-111" class="menu-item menu-item-type-taxonomy menu-item-object-managing_diabetes_cat menu-item-111"><a href="https://www.diabetesselfmanagement.com/managing-diabetes/emotional-health/">Emotional Health</a></li>
	<li id="menu-item-112" class="menu-item menu-item-type-taxonomy menu-item-object-managing_diabetes_cat menu-item-112"><a href="https://www.diabetesselfmanagement.com/managing-diabetes/general-health-issues/">General Health Issues</a></li>
	<li id="menu-item-113" class="menu-item menu-item-type-taxonomy menu-item-object-managing_diabetes_cat menu-item-113"><a href="https://www.diabetesselfmanagement.com/managing-diabetes/getting-to-know-you/">Getting to Know You</a></li>
</ul>
</li>
<li id="menu-item-129" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-129"><a href="http://www.diabetesselfmanagement.com/recipes/">Diabetes Recipes</a>
<ul  class="sub-menu">
	<li id="menu-item-132" class="menu-item menu-item-type-taxonomy menu-item-object-meal_type menu-item-132"><a href="https://www.diabetesselfmanagement.com/recipes/beverages/">Diabetic Drinks &amp; Beverages</a></li>
	<li id="menu-item-133" class="menu-item menu-item-type-taxonomy menu-item-object-meal_type menu-item-133"><a href="https://www.diabetesselfmanagement.com/recipes/breakfast/">Diabetic Breakfast Recipes</a></li>
	<li id="menu-item-134" class="menu-item menu-item-type-taxonomy menu-item-object-meal_type menu-item-134"><a href="https://www.diabetesselfmanagement.com/recipes/desserts-sweets/">Desserts &#038; Sweets</a></li>
	<li id="menu-item-135" class="menu-item menu-item-type-taxonomy menu-item-object-meal_type menu-item-135"><a href="https://www.diabetesselfmanagement.com/recipes/main-dishes/">Diabetic Dinner Recipes</a></li>
	<li id="menu-item-136" class="menu-item menu-item-type-taxonomy menu-item-object-meal_type menu-item-136"><a href="https://www.diabetesselfmanagement.com/recipes/salads/">Salad Recipes for Diabetics</a></li>
	<li id="menu-item-137" class="menu-item menu-item-type-taxonomy menu-item-object-meal_type menu-item-137"><a href="https://www.diabetesselfmanagement.com/recipes/sides/">Diabetic Side Dish Recipes</a></li>
	<li id="menu-item-138" class="menu-item menu-item-type-taxonomy menu-item-object-meal_type menu-item-138"><a href="https://www.diabetesselfmanagement.com/recipes/snacks-appetizers/">Snacks &#038; Appetizers</a></li>
	<li id="menu-item-139" class="menu-item menu-item-type-taxonomy menu-item-object-meal_type current-recipe-ancestor current-menu-parent current-recipe-parent menu-item-139"><a href="https://www.diabetesselfmanagement.com/recipes/soups-stews/">Soups &#038; Stews</a></li>
</ul>
</li>
<li id="menu-item-130" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-130"><a href="http://www.diabetesselfmanagement.com/nutrition-exercise/">Nutrition &#038; Exercise</a>
<ul  class="sub-menu">
	<li id="menu-item-123" class="menu-item menu-item-type-taxonomy menu-item-object-nutrition_exercise_cat menu-item-123"><a href="https://www.diabetesselfmanagement.com/nutrition-exercise/exercise/">Exercise</a></li>
	<li id="menu-item-124" class="menu-item menu-item-type-taxonomy menu-item-object-nutrition_exercise_cat menu-item-124"><a href="https://www.diabetesselfmanagement.com/nutrition-exercise/meal-planning/">Diabetic Meal Planning</a></li>
	<li id="menu-item-126" class="menu-item menu-item-type-taxonomy menu-item-object-nutrition_exercise_cat menu-item-126"><a href="https://www.diabetesselfmanagement.com/nutrition-exercise/weight-loss-management/">Weight Loss &#038; Management</a></li>
	<li id="menu-item-125" class="menu-item menu-item-type-taxonomy menu-item-object-nutrition_exercise_cat menu-item-125"><a href="https://www.diabetesselfmanagement.com/nutrition-exercise/nutrition/">Nutrition &amp; Diabetes</a></li>
</ul>
</li>
<li id="menu-item-131" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-131"><a href="http://www.diabetesselfmanagement.com/diabetes-resources/">Diabetes Resources</a>
<ul  class="sub-menu">
	<li id="menu-item-20830" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-20830"><a href="http://www.diabetesselfmanagement.com/videos/">Diabetes Videos</a></li>
	<li id="menu-item-116" class="menu-item menu-item-type-taxonomy menu-item-object-diabetes_resource_cat menu-item-116"><a href="https://www.diabetesselfmanagement.com/diabetes-resources/definitions/">Definitions</a></li>
	<li id="menu-item-117" class="menu-item menu-item-type-taxonomy menu-item-object-diabetes_resource_cat menu-item-117"><a href="https://www.diabetesselfmanagement.com/diabetes-resources/money-matters/">Money Matters</a></li>
	<li id="menu-item-118" class="menu-item menu-item-type-taxonomy menu-item-object-diabetes_resource_cat menu-item-118"><a href="https://www.diabetesselfmanagement.com/diabetes-resources/tools-tech/">Tools &#038; Tech</a></li>
	<li id="menu-item-17181" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17181"><a href="http://www.diabetesselfmanagement.com/diabetes-resources/consumer-products/consumer-products-list/">Consumer Products</a></li>
</ul>
</li>
<li id="menu-item-1261" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1261"><a href="http://www.diabetesselfmanagement.com/blog/">Blog</a></li>
</ul></div>		</nav><!-- #site-navigation -->
	</header><!-- #masthead -->
			<div class="ad-header" style="margin: 10px; background-color: transparent;">
			<div class="txt-c">
				<div class="ad ad--leaderboard">
				<div class="txt-c ad__heading screen-reader-text"><small>Advertisement</small></div>
					<div id="div-ad-leaderboarda">
<script type="text/javascript">
googletag.display('div-ad-leaderboarda');
</script>
</div>
				</div>
			</div>
		</div>
		<div id="content" class="site-content">
		<div class="wrapper">
		
	<div id="primary" class="content-area">
		<main id="main" class="site-main" role="main">
		
				<div class="page-links breadcrumbs" xmlns:v="http://rdf.data-vocabulary.org/#">
			<!-- Breadcrumb NavXT 5.7.1 -->
<span typeof="v:Breadcrumb"><a rel="v:url" property="v:title" title="Go to Diabetes Self-Management." href="https://www.diabetesselfmanagement.com" class="home">Home</a></span> &gt; <span typeof="v:Breadcrumb"><a rel="v:url" property="v:title" title="Go to Recipes." href="https://www.diabetesselfmanagement.com/recipes/">Recipes</a></span> &gt; <span typeof="v:Breadcrumb"><a rel="v:url" property="v:title" title="Go to the Diabetic Soup And Stew Recipes Meal Type archives." href="https://www.diabetesselfmanagement.com/recipes/soups-stews/">Diabetic Soup And Stew Recipes</a></span> &gt; <span typeof="v:Breadcrumb"><a rel="v:url" property="v:title" title="Go to Butternut Squash and Millet Soup." href="https://www.diabetesselfmanagement.com/recipes/soups-stews/butternut-squash-millet-soup/">Butternut Squash and Millet Soup</a></span>		</div>
				
		
			
<article class="current-article post-30219 recipe type-recipe status-publish has-post-thumbnail hentry meal_type-soups-stews" itemscope itemtype="http://schema.org/Recipe" id="post-30219">
	<div class="recipe-dc_heading">
				<p><img alt="Diabetic Cooking" src="https://www.diabetesselfmanagement.com/wp-content/themes/diabetesselfmanagement/images/diabetic-cooking-red2x.png" width="155" /></p>
	</div>
		<div class="featured-image">
		<img width="400" height="250" src="https://cdn.diabetesselfmanagement.com/2017/10/Butternut-Squash-and-Millet-Soup-400x250.jpg" class="attachment-article-cat-large size-article-cat-large wp-post-image" alt="Butternut Squash and Millet Soup" title="Butternut Squash and Millet Soup" itemprop="image" />	</div>
		
	<div class="utility col-wrap clearfix">
				<p class="meal-types col palm-one-whole lap-one-half desk-two-thirds"><span itemprop="recipeCategory"><a href="https://www.diabetesselfmanagement.com/recipes/soups-stews/">Diabetic Soup And Stew Recipes</a></span></p>	
				<p class="utility_links col palm-one-whole lap-one-half desk-one-third">
			<a class="print_link" href="https://www.diabetesselfmanagement.com/recipes/soups-stews/butternut-squash-millet-soup/?print=0"><i class="icon-print"></i> Print</a>			<span class="text-size-adjust">
				<span class="text-size-adjust_heading">Text Size:</span> 
				<a class="text-size-adjust_control text-size-adjust_small" href="#nogo">A</a>
				<a class="text-size-adjust_control text-size-adjust_medium" href="#nogo">A</a>
				<a class="text-size-adjust_control text-size-adjust_large" href="#nogo">A</a>
			</span>
		</p>
	</div>
	
	
	<header class="hr entry-header">
		<h1 class="entry-title"><span itemprop="name">Butternut Squash and Millet Soup</span>  <div style="float: right; display: inline-block; vertical-align: middle;" class="addthis_inline_share_toolbox_a2zf"></div></h1>  
		<span style="display: none;"><span class="posted-on"><time class="entry-date updated published" datetime="2017-10-22T13:00:45+00:00">Published October 22, 2017</time></span><span class="byline"> by <span class="author vcard" style="display: none;"><span class="fn">Diabetes Self-Management</span></span></span></span>
	</header>
	
	<div class="entry-content recipe--has-ad">
		<div class="article-intro">
					</div>
		
				
				<div class="alignleft">
			<div class="ad ad--skyscraper">
				<div class="txt-c ad__heading"><small>Advertisement</small></div>
									<div id="div-ad-skyscrapera">
<script type="text/javascript">
googletag.display('div-ad-skyscrapera');
</script>
</div>
							</div>
		</div>
				
				<div class="recipe-ingredients">
			<h3>Ingredients</h3>
			<ul>
							<li itemprop="ingredients">1 red bell pepper</li>
							<li itemprop="ingredients">1 teaspoon canola oil</li>
							<li itemprop="ingredients">2 1/4 cups diced butternut squash <i>or</i> 1 (10-ounce) package frozen diced butternut squash</li>
							<li itemprop="ingredients">1 medium red onion, chopped</li>
							<li itemprop="ingredients">1 teaspoon curry powder</li>
							<li itemprop="ingredients">1/2 teaspoon smoked paprika</li>
							<li itemprop="ingredients">1/2 teaspoon salt</li>
							<li itemprop="ingredients">1/8 teaspoon black pepper</li>
							<li itemprop="ingredients">2 cups low-sodium chicken broth</li>
							<li itemprop="ingredients">2 boneless skinless chicken breasts (about 4 ounces each), cooked and chopped</li>
							<li itemprop="ingredients">1 cup cooked millet</li>
						</ul>
		</div>
				
				<div class="recipe-directions" itemprop="recipeInstructions">
			<h3>Directions</h3>
			<p>Place bell pepper on rack in broiler pan 3 to 5 inches from heat source or hold over open gas flame on long-handled metal fork. Turn bell pepper often until blistered and charred on all sides. Transfer to food storage bag; seal bag and let stand 15 to 20 minutes to loosen skin. Remove loosened skin with paring knife. Cut off top and scrape out seeds; discard.</p>
<p>Heat oil in large saucepan over high heat. Add butternut squash, bell pepper, and onion; cook and stir 5 minutes. Add curry powder, paprika, salt, and black pepper. Pour in broth; bring to a boil. Cover and cook 7 to 10 minutes or until vegetables are tender.</p>
<p>Purée soup in saucepan with hand-held immersion blender or in batches in food processor or blender. Return soup to saucepan. Stir in chicken and millet; cook until heated through.</p>
		</div>
				
		<div class="recipe-callout">
			<div class="callout callout--c">
									<p><strong>Yield:</strong> <span itemprop="recipeYield">6 servings</span>. 					
					<strong>Serving size:</strong> <span itemprop="nutrition"><span itemprop="servingSize">1 1/3 cups</span></span>.</p>
								
				<p><strong>Nutrition Facts Per Serving:</strong><br />
					Calories: <span itemprop="nutrition"><span itemprop="calories">168 calories</span></span>, Carbohydrates: <span itemprop="nutrition"><span itemprop="carbohydrateContent">19 g</span></span>, Protein: <span itemprop="nutrition"><span itemprop="proteinContent">16 g</span></span>, Fat: <span itemprop="nutrition"><span itemprop="fatContent">3 g</span></span>, Saturated Fat: <span itemprop="nutrition"><span itemprop="saturatedFatContent">1 g</span></span>, Cholesterol: <span itemprop="nutrition"><span itemprop="cholesterolContent">37 mg</span></span>, Sodium: <span itemprop="nutrition"><span itemprop="sodiumContent">199 mg</span></span>, Fiber: <span itemprop="nutrition"><span itemprop="fiberContent">2 g</span></span>				</p>
				
								
					<p><strong>Exchanges per serving:</strong> 1 Bread/Starch, 1 Vegetable, 2 Mea. 					
					</p>
							</div>
							<div style="display: inline-block;" class="addthis_sharing_toolbox"></div>
		</div>
		
		<div class="col-wrap clearfix recipe-foot-cta">
			<div class="col one-half">&nbsp;
			</div>
			<div class="col one-half">
				<p class="meal-types-cta txt-r"><a href="https://www.diabetesselfmanagement.com/recipes/soups-stews/">See more Diabetic Soup And Stew Recipes<i class="icon-right-open"></i></a> </p>			</div>
		</div>
		
<script type="text/javascript">
window._mNHandle = window._mNHandle || {};
window._mNHandle.queue = window._mNHandle.queue || [];
medianet_versionId = "121199"; 
(function() {
	var sct = document.createElement("script"),
	sctHl = document.getElementsByTagName("script")[0],
	isSSL = 'https:' == document.location.protocol;
	sct.type = "text/javascript";
	sct.src = (isSSL ? 'https:' : 'http:') + '//contextual.media.net/dmedianet.js?cid=8CUVGXD58' + (isSSL ? '&https=1' : '')+'';
	sct.async = "async";
	sctHl.parentNode.insertBefore(sct, sctHl);
})();
</script>
<div id="951681667" class="timing" style="border-bottom: 0;">
<script type="text/javascript">
  try {
	   window._mNHandle.queue.push(function () {
		window._mNDetails.loadTag("951681667", "825x200", "951681667");
		});
	  }
  catch (error) {}
</script>
</div>

	
				<div class="short-divider"><hr></div>
		<div class="recipe-additional-info">
			<p><em>Copyright Diabetic Cooking.</em></p>
		</div>
				<div class="entry-footer__disclaimer">
			<p>Disclaimer Statements: Statements and opinions expressed on this Web site are those of the authors and not necessarily those of the publishers or advertisers. The information provided on this Web site should not be construed as medical instruction. Consult appropriate health-care professionals before taking action based on this information.</p>
		</div>
	</div>
</article>

		
		</main><!-- #main -->
	</div><!-- #primary -->


<div id="secondary" class="widget-area" role="complementary">
		
		
		
		
				<div class="col-wrap clearfix">
				<div class="col palm-one-whole lap-one-half desk-one-whole">
							<div class="widget widget--ad widget--ad-1 txt-c">
			<div class="ad ad--box">
				<div class="txt-c ad__heading"><small>Advertisement</small></div>		
				<div id="div-ad-boxa">
<script type="text/javascript">
googletag.display('div-ad-boxa');
</script>
</div>
			</div>
		</div>
						</div>
				<div class="col palm-one-whole lap-one-half desk-one-whole">
					<div class="widget widget--recent-articles">
	<h3 class="widget-title">Recent Articles</h3>
		<div class="widget-content">
		<ul class="ul-divided">
					<li><a href="https://www.diabetesselfmanagement.com/nutrition-exercise/meal-planning/smart-snacking-diabetes/protein-bars/" onclick="dataLayer.push({'event':'GAevent','eventCategory': 'Recent Articles', 'eventAction': 'Click-Desktop', 'eventLabel':'https://www.diabetesselfmanagement.com/nutrition-exercise/meal-planning/smart-snacking-diabetes/protein-bars/'});">Protein Bars</a></li>
					<li><a href="https://www.diabetesselfmanagement.com/nutrition-exercise/meal-planning/smart-snacking-diabetes/" onclick="dataLayer.push({'event':'GAevent','eventCategory': 'Recent Articles', 'eventAction': 'Click-Desktop', 'eventLabel':'https://www.diabetesselfmanagement.com/nutrition-exercise/meal-planning/smart-snacking-diabetes/'});">Smart Snacking With Diabetes</a></li>
					<li><a href="https://www.diabetesselfmanagement.com/managing-diabetes/complications-prevention/heart-disease-quiz/" onclick="dataLayer.push({'event':'GAevent','eventCategory': 'Recent Articles', 'eventAction': 'Click-Desktop', 'eventLabel':'https://www.diabetesselfmanagement.com/managing-diabetes/complications-prevention/heart-disease-quiz/'});">Heart Disease Quiz</a></li>
					<li><a href="https://www.diabetesselfmanagement.com/diabetes-resources/definitions/heart-failure/" onclick="dataLayer.push({'event':'GAevent','eventCategory': 'Recent Articles', 'eventAction': 'Click-Desktop', 'eventLabel':'https://www.diabetesselfmanagement.com/diabetes-resources/definitions/heart-failure/'});">Heart Failure</a></li>
				</ul>
		
		<p><a class="btn btn--a" href="https://www.diabetesselfmanagement.com/">More Diabetes Articles</a></p>
		</div>
</div>
				</div>
			</div>
			<div class="col-wrap clearfix">
				<div class="col palm-one-whole lap-one-half desk-one-whole">			
					<div class="widget widget--ad widget--ad-2">
	<div class="ad ad--box txt-c">
		<div class="txt-c ad__heading"><small>Advertisement</small></div>
		<div id="div-ad-boxb">
<script type="text/javascript">
googletag.display('div-ad-boxb');
</script>
</div>
	</div>
</div>
				</div>
				<div class="col palm-one-whole lap-one-half desk-one-whole">	
					<div class="widget widget--recent-blog">
	<h3 class="widget-title">Recent Blog Posts</h3>
		<div class="widget-content">
		<ul class="ul-divided">
					<li><a href="https://www.diabetesselfmanagement.com/blog/caffeine-benefits-women-diabetes/" onclick="dataLayer.push({'event':'GAevent','eventCategory': 'Recent Blogs', 'eventAction': 'Click-Desktop', 'eventLabel':'https://www.diabetesselfmanagement.com/blog/caffeine-benefits-women-diabetes/'});">Caffeine’s Benefits in Women With Diabetes</a></li>
					<li><a href="https://www.diabetesselfmanagement.com/blog/aspirin-breast-cancer-type-2-diabetes/" onclick="dataLayer.push({'event':'GAevent','eventCategory': 'Recent Blogs', 'eventAction': 'Click-Desktop', 'eventLabel':'https://www.diabetesselfmanagement.com/blog/aspirin-breast-cancer-type-2-diabetes/'});">Aspirin, Breast Cancer, and Type 2 Diabetes</a></li>
					<li><a href="https://www.diabetesselfmanagement.com/blog/emotional-toll-diabetes/" onclick="dataLayer.push({'event':'GAevent','eventCategory': 'Recent Blogs', 'eventAction': 'Click-Desktop', 'eventLabel':'https://www.diabetesselfmanagement.com/blog/emotional-toll-diabetes/'});">The Emotional Toll of Diabetes</a></li>
					<li><a href="https://www.diabetesselfmanagement.com/blog/health-insurance-diabetes/" onclick="dataLayer.push({'event':'GAevent','eventCategory': 'Recent Blogs', 'eventAction': 'Click-Desktop', 'eventLabel':'https://www.diabetesselfmanagement.com/blog/health-insurance-diabetes/'});">Health Insurance for Diabetes?</a></li>
				</ul>
		
		<p><a class="btn btn--a" href="https://www.diabetesselfmanagement.com/blog/">More Diabetes Blog Posts</a></p>
		</div>
</div>				</div>
			</div>
			<div class="col-wrap clearfix">
				<div class="col palm-one-whole lap-one-half desk-one-whole">
					
<div class="widget widget--recent-articles">
	<div class="callout" style="border-color: #23589A;">
	<h3 class="widget-title">Editor's Picks</h3>
	<div class="widget-content">
	<ul class="ul-divided">
							<li><a href="https://www.diabetesselfmanagement.com/blog/what-is-a-normal-blood-sugar-level/" class="ga_tracker_EditorsPicks">What Is a Normal Blood Sugar Level? </a></li>
									<li><a href="https://www.diabetesselfmanagement.com/managing-diabetes/treatment-approaches/metformin-2/" class="ga_tracker_EditorsPicks">Metformin:<br />The Unauthorized Biography </a></li>
									<li><a href="https://www.diabetesselfmanagement.com/managing-diabetes/blood-glucose-management/strike-the-spike-ii/" class="ga_tracker_EditorsPicks">Strike the Spike II:<br />Dealing With High Blood Sugar After Meals </a></li>
									<li><a href="https://www.diabetesselfmanagement.com/blog/what-causes-diabetes-fatigue/" class="ga_tracker_EditorsPicks">What Causes Diabetes Fatigue? </a></li>
									<li><a href="https://www.diabetesselfmanagement.com/blog/bitter-melon-diabetes-news/" class="ga_tracker_EditorsPicks">Bitter Melon Diabetes News </a></li>
					</ul>
				</div>
	</div>
</div>

				</div>
				<div class="col palm-one-whole lap-one-half desk-one-whole">
					<div class="widget widget-newsletter">
	<div class="newsletter callout callout--a">
		<h3 class="newsletter__heading">Sign up for our Newsletter</h3>
		<span>Enter your email address to receive our weekly newsletter.</span>
		<form action="https://cl.exct.net/subscribe.aspx?lid=33179486" name="subscribeForm" method="post">
			<input type="hidden" name="thx" value="http://www.diabetesselfmanagement.com/newsletter/confirm/">
			<input type="hidden" name="err" value="http://www.diabetesselfmanagement.com/newsletter/error/">
			<input type="hidden" name="usub" value="http://www.diabetesselfmanagement.com/newsletter/confirm/">
			<input type="hidden" name="Email Type" value="HTML" checked="checked">
			<input type="hidden" name="SubAction" value="sub_add_update" checked="checked">
			<input type="hidden" name="MID" value="10916430">
						<p><input style="width: 65%;" type="text" id="Email Address" class="flatfield" placeholder="Enter your e-mail address" name="Email Address">
			<input type="submit" value="Submit"></p>
		</form>
	</div>
</div>

				</div>
			</div>
			<div class="col-wrap clearfix">
				<div class="col palm-one-whole lap-one-half desk-one-whole">
					
				</div>
			</div>
		
	</div><!-- #secondary -->
		</div>
	</div><!-- #content -->

	<footer id="colophon" class="site-footer" role="contentinfo">
		<div class="wrapper" >
			<div class="clear">
				<div class="site-footer__branding">
					<a href="https://www.diabetesselfmanagement.com/" rel="home"><img alt="Diabetes Self-Management" src="https://www.diabetesselfmanagement.com/wp-content/themes/diabetesselfmanagement/images/logo2x.png" width="150" /></a>
				</div><!-- .site-footer__branding -->
				<div class="site-footer__site-map">
					<div class="menu-secondary-container"><ul id="menu-secondary" class="menu"><li id="menu-item-85" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-85"> <a href="https://www.diabetesselfmanagement.com/subscribe/">Subscribe</a> </li>
<li id="menu-item-17492" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-17492"> <a href="https://www.diabetesselfmanagement.com/digital-editions/">Digital&nbsp;Editions</a> </li>
<li id="menu-item-86" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-86"> <a href="https://www.diabetesselfmanagement.com/about-us/">About&nbsp;Us</a> </li>
<li id="menu-item-87" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87"> <a href="https://www.diabetesselfmanagement.com/contact/">Contact</a> </li>
<li id="menu-item-10069" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10069"> <a href="https://www.diabetesselfmanagement.com/newsletter/">Newsletter</a> </li>
<li id="menu-item-88" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-88"> <a href="https://www.diabetesselfmanagement.com/advertise/">Advertise</a> </li>
<li id="menu-item-89" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-89"> <a href="https://www.diabetesselfmanagement.com/privacy-policy/">Privacy&nbsp;Policy</a> </li>
<li id="menu-item-10072" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10072"> <a href="https://www.diabetesselfmanagement.com/terms-use/">Terms&nbsp;of&nbsp;Use</a> </li>
</ul></div>				</div><!-- .site-footer__site-map -->
				<div class="site-footer__social">
					<ul class="social-nav">
		<li class="social-nav__item social-nav__facebook"><a class="icon icon-facebook-circled" href="https://www.facebook.com/DiabetesSelfManagement" target="_blank"><span class="screen-reader-text">Facebook</span></a></li>
			<li class="social-nav__item social-nav__twitter"><a class="icon icon-twitter-circled" href="https://twitter.com/ManageDiabetes" target="_blank"><span class="screen-reader-text">Twitter</span></a></li>
			<li class="social-nav__item social-nav__pinterest"><a class="icon icon-pinterest" href="https://www.pinterest.com/diabetesrecipes/" target="_blank"><span class="screen-reader-text">Pinterest</span></a></li>
		</ul>				</div><!-- .site-footer__social -->
			</div>
			<div class="site-footer__legal">
								<p><a href="https://www.healthonnet.org/HONcode/Conduct.html?HONConduct248569" onclick="window.open(this.href); return false;"> <img src="https://www.honcode.ch/HONcode/Seal/HONConduct248569_s.gif" width="49" height="72" style="border:0px;padding-right:20px;vertical-align:middle;" title="This website is certified by Health On the Net Foundation. Click to verify." alt="This website is certified by Health On the Net Foundation. Click to verify."></a>
				

				
				&copy; 2017 Madavor Media, LLC. All Rights Reserved.</p>
			</div><!-- .site-info -->
		</div>
		<br />&nbsp;<br />&nbsp;<br />
	</footer><!-- #colophon -->
</div><!-- #page -->

<script type='text/javascript' data-cfasync="false" async src='//widgets.getsitecontrol.com/52448/script.js?ver=2.0.5'></script>
<script type='text/javascript' src='https://www.diabetesselfmanagement.com/wp-content/themes/diabetesselfmanagement/js/global-min.js?ver=20159197'></script>
<script type='text/javascript' src='https://www.diabetesselfmanagement.com/wp-includes/js/wp-embed.min.js?ver=e80099dd32ec93390998d532cb3193c7'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"diabetesselfmanagement"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.diabetesselfmanagement.com/wp-content/plugins/disqus-comment-system/media/js/count.js?ver=e80099dd32ec93390998d532cb3193c7'></script>
<div id="div-nextmillenium">
<script type="text/javascript">
googletag.display('div-nextmillenium');
</script>
</div>
</body>
</html>
