<!DOCTYPE html> <!--[if lt IE 7]><html class="lt-ie9 lt-ie8 lt-ie7" lang="en-US" prefix="og: http://ogp.me/ns#"> <![endif]--> <!--[if IE 7]><html class="lt-ie9 lt-ie8" lang="en-US" prefix="og: http://ogp.me/ns#"> <![endif]--> <!--[if IE 8]><html class="lt-ie9" lang="en-US" prefix="og: http://ogp.me/ns#"> <![endif]--> <!--[if gt IE 8]><!--><html lang="en-US" prefix="og: http://ogp.me/ns#"> <!--<![endif]--><head><meta charset="UTF-8"><meta name="viewport" content="width=device-width, initial-scale=1"><meta name="google-site-verification" content="iHjHaLAShqtJQADuRq3V1yv3UpMbqP-Dlcm_6KwJsYw" /><script data-cfasync="false" id="ao_optimized_gfonts_config" type="text/javascript">WebFontConfig={google:{families:["Open Sans:400italic,600italic,700italic,400,600,700:latin,latin-ext"] },classes:false, events:false, timeout:1500};</script><link rel="profile" href="https://gmpg.org/xfn/11"><link rel="pingback" href="https://www.diabetesselfmanagement.com/xmlrpc.php"> <script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-5877cba327754b5f"></script> <script>dataLayer = [];</script> <script>dataLayer = [{
	'event': 'dataLayer_load',
	'PrimaryCategory': 'Medical Health>Diseases and Conditions>Diabetes',
	'SecondaryCategory': 'Fitness and Exercise, Medical Health, Running and Jogging',
	'Topics': 'aerobic exercise, bariatrics, body shape, clinical medicine, determinants of health, dieting, eating behaviors of humans, exercise, health, health care, health education, health promotion, high-intensity interval training, hobbies, human activities, human weight, hyperalimentation, management of obesity, medical specialties, medical treatments, metabolic disorders, nutrition, obesity, physical exercise, physical fitness, public health, recreation, self-care, sports, strength training, weight loss',
  'DSM_DiabetesType': 'Both'
}];</script> <!-- BEGIN ControlTag for DSM --> <script class='kxct' data-id='txnbcm4ag' data-timing='async' data-version='3.0' type='text/javascript'>window.Krux||((Krux=function(){Krux.q.push(arguments)}).q=[]);
  (function(){
    var k=document.createElement('script');k.type='text/javascript';k.async=true;
    k.src=(location.protocol==='https:'?'https:':'http:')+'//cdn.krxd.net/controltag/txnbcm4ag.js';
    var s=document.getElementsByTagName('script')[0];s.parentNode.insertBefore(k,s);
  }());</script> <!-- END ControlTag --> <script class='kxint' data-namespace='madavormedia' type='text/javascript'>window.Krux||((Krux=function(){Krux.q.push(arguments);}).q=[]);
(function(){
  function retrieve(n){
    var k= 'kx'+'madavormedia_'+n, ls=(function(){
      try {
        return window.localStorage;
      } catch(e) {
        return null;
      }
    })();
    if (ls) {
        return ls[k] || '';
    } else if (navigator.cookieEnabled) {
        var m = document.cookie.match(k+'=([^;]*)');
        return (m && unescape(m[1])) || '';
    } else {
        return '';
    }
  }
  Krux.user = retrieve('user');
  Krux.segments = retrieve('segs') ? retrieve('segs').split(',') : [];
})();</script> <link type="text/css" media="all" href="https://www.diabetesselfmanagement.com/wp-content/cache/autoptimize/css/autoptimize_4a5738923ce976a87b955191a70ac2de.css" rel="stylesheet" /><link type="text/css" media="screen" href="https://www.diabetesselfmanagement.com/wp-content/cache/autoptimize/css/autoptimize_a318e34a19c5647cc570eead676317f3.css" rel="stylesheet" /><title>Choosing the Right Fitness Program for You - Exercise &amp; Nutrition for Diabetics | Diabetes Self-Management</title> <!-- This site is optimized with the Yoast SEO Premium plugin v8.4 - https://yoast.com/wordpress/plugins/seo/ --><meta name="description" content="To maintain a healthy weight, you need to work on your fitness. The first place to start is choosing the right fitness program for you."/><link rel="canonical" href="https://www.diabetesselfmanagement.com/nutrition-exercise/exercise/choosing-right-fitness-program/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Choosing the Right Fitness Program for You - Exercise &amp; Nutrition for Diabetics | Diabetes Self-Management" /><meta property="og:description" content="To maintain a healthy weight, you need to work on your fitness. The first place to start is choosing the right fitness program for you." /><meta property="og:url" content="https://www.diabetesselfmanagement.com/nutrition-exercise/exercise/choosing-right-fitness-program/" /><meta property="og:site_name" content="Diabetes Self-Management" /><meta property="og:image" content="https://cdn.diabetesselfmanagement.com/2019/12/shutterstock_310054760.jpg" /><meta property="og:image:secure_url" content="https://cdn.diabetesselfmanagement.com/2019/12/shutterstock_310054760.jpg" /><meta property="og:image:width" content="1000" /><meta property="og:image:height" content="667" /><meta property="og:image:alt" content="Happy people dancing -- Choosing the Right Fitness Program for You" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:description" content="To maintain a healthy weight, you need to work on your fitness. The first place to start is choosing the right fitness program for you." /><meta name="twitter:title" content="Choosing the Right Fitness Program for You - Exercise &amp; Nutrition for Diabetics | Diabetes Self-Management" /><meta name="twitter:image" content="https://cdn.diabetesselfmanagement.com/2019/12/shutterstock_310054760.jpg" /> <!-- / Yoast SEO Premium plugin. --><link rel='dns-prefetch' href='//widgets.getsitecontrol.com' /><link href='https://fonts.gstatic.com' crossorigin='anonymous' rel='preconnect' /><link href='https://ajax.googleapis.com' rel='preconnect' /><link href='https://fonts.googleapis.com' rel='preconnect' /><link rel="alternate" type="application/rss+xml" title="Diabetes Self-Management &raquo; Feed" href="https://www.diabetesselfmanagement.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Diabetes Self-Management &raquo; Comments Feed" href="https://www.diabetesselfmanagement.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Diabetes Self-Management &raquo; Choosing the Right Fitness Program for You Comments Feed" href="https://www.diabetesselfmanagement.com/nutrition-exercise/exercise/choosing-right-fitness-program/feed/" /><link rel='stylesheet' id='dashicons-css'  href='https://www.diabetesselfmanagement.com/wp-includes/css/dashicons.min.css?ver=ba455dc74f620980177cc6e04271a0cd' type='text/css' media='all' /> <!--[if lt IE 9]><link rel='stylesheet' id='diabetesselfmanagement-ie-css'  href='https://www.diabetesselfmanagement.com/wp-content/themes/dsmrefresh/css/ie.css?ver=20141205' type='text/css' media='all' /> <![endif]--> <script type='text/javascript' src='https://www.diabetesselfmanagement.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script> <script type='text/javascript'>/* <![CDATA[ */
var Cli_Data = {"nn_cookie_ids":[],"cookielist":[]};
var log_object = {"ajax_url":"https:\/\/www.diabetesselfmanagement.com\/wp-admin\/admin-ajax.php"};
/* ]]> */</script> <link rel='https://api.w.org/' href='https://www.diabetesselfmanagement.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.diabetesselfmanagement.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.diabetesselfmanagement.com/wp-includes/wlwmanifest.xml" /><link rel='shortlink' href='https://www.diabetesselfmanagement.com/?p=43653' /><link rel="alternate" type="application/json+oembed" href="https://www.diabetesselfmanagement.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.diabetesselfmanagement.com%2Fnutrition-exercise%2Fexercise%2Fchoosing-right-fitness-program%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.diabetesselfmanagement.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.diabetesselfmanagement.com%2Fnutrition-exercise%2Fexercise%2Fchoosing-right-fitness-program%2F&#038;format=xml" /> <script async src="https://www.googletagmanager.com/gtag/js?id=UA-139901603-1"></script> <script>window.dataLayer = window.dataLayer || [];
			function gtag(){dataLayer.push(arguments);}
			gtag('js', new Date());
			gtag('config', 'UA-139901603-1');</script> <!-- BEGIN wp-parsely Plugin Version 2.0 --><meta name="wp-parsely_version" id="wp-parsely_version" content="2.0"/> <!-- parsleyPage is not defined / has no attributes.  What kind of page are you loading? --> <!-- END wp-parsely Plugin Version 2.0 --> <!--<meta name="NextGEN" version="3.2.15" /> --> <script type='text/javascript'>(function() {
var useSSL = 'https:' == document.location.protocol;
var src = (useSSL ? 'https:' : 'http:') +
'//www.googletagservices.com/tag/js/gpt.js';
document.write('<scr' + 'ipt src="' + src + '"></scr' + 'ipt>');
})();</script> <script type='text/javascript'>googletag.defineSlot('/8842/DSM/nutrition-exercise/exercise', [728, 90], 'div-ad-leaderboarda').setTargeting('pos','L1').addService(googletag.pubads());
googletag.defineSlot('/8842/DSM/nutrition-exercise/exercise', [728, 90], 'div-ad-leaderboardb').setTargeting('pos','L2').addService(googletag.pubads());
googletag.defineSlot('/8842/DSM/nutrition-exercise/exercise', [728, 90], 'div-ad-leaderboardc').setTargeting('pos','in-content1').addService(googletag.pubads());
googletag.defineSlot('/8842/DSM/nutrition-exercise/exercise', [728, 90], 'div-ad-leaderboardd').setTargeting('pos','in-content2').addService(googletag.pubads());
googletag.defineSlot('/8842/DSM/nutrition-exercise/exercise', [300, 250], 'div-ad-boxa').setTargeting('pos','1').addService(googletag.pubads());
googletag.defineSlot('/8842/DSM/nutrition-exercise/exercise', [300, 600], 'div-ad-boxb').setTargeting('pos','2').addService(googletag.pubads());
googletag.defineSlot('/8842/DSM/nutrition-exercise/exercise', [[300, 250], [300, 252]], 'div-ad-boxc').setTargeting('pos','3').addService(googletag.pubads());
googletag.defineSlot('/8842/DSM/nutrition-exercise/exercise', [[300, 250], [300, 253]], 'div-ad-boxd').setTargeting('pos','4').addService(googletag.pubads());
googletag.defineSlot('/8842/DSM/nutrition-exercise/exercise', [160, 600], 'div-ad-skyscrapera').addService(googletag.pubads());
googletag.defineSlot('/8842/DSM/nutrition-exercise/exercise', [728, 90], 'div-ad-leaderboarde').setTargeting('pos','in-content3').addService(googletag.pubads());
googletag.defineSlot('/8842/DSM/nutrition-exercise/exercise', [1, 1], 'interstitial').setTargeting('pos','1x1').addService(googletag.pubads());
googletag.defineOutOfPageSlot('/8842/DSM/nutrition-exercise/exercise', 'div-oop').addService(googletag.pubads());
googletag.defineSlot('/8842/DSM/nutrition-exercise/exercise', [[970, 250], [728, 90]], 'div-ad-superleaderboarda').setTargeting('pos','S1').addService(googletag.pubads());
googletag.pubads().setTargeting('Device','Desktop');
googletag.pubads().setTargeting('Age_Range',['18_to_20', '18_to_20_or_Unknown', '21_to_24_or_Unknown', '21-to_24', '25_to_34', '25_to_34_or_Unknown', '35_to_44', '35_to_44_or_Unknown', '45_to_49', '45_to_49_or_Unknown', '50_to_54', '50_to_54_or_Unknown', '55_to_64', '55_to_64_or_Unknown', '64_and_Over_or_Unknown', '65_and_Over']);
googletag.pubads().setTargeting('Gender',['Female', 'Female_or_unknown', 'Male', 'Male_or_unknown']);
googletag.pubads().setTargeting('A',['Jenny Craig','Trulicity']);
googletag.pubads().setTargeting('X',['Baqsimi']);
googletag.pubads().setTargeting('T',['/nutrition-exercise/exercise/choosing-right-fitness-program/','/nutrition-exercise/exercise/choosing-right-fitness-program']);
googletag.pubads().enableSingleRequest();
googletag.enableServices();</script> <!-- Facebook Pixel Code --> <script>!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','https://connect.facebook.net/en_US/fbevents.js');
fbq('init', '1454562221311729');
fbq('track', 'PageView');</script> <noscript><img height="1" width="1" style="display:none"
src="https://www.facebook.com/tr?id=1454562221311729&ev=PageView&noscript=1"
/></noscript> <!-- DO NOT MODIFY --> <!-- End Facebook Pixel Code --> <script type="text/javascript">window._mNHandle = window._mNHandle || {};
			window._mNHandle.queue = window._mNHandle.queue || [];
			medianet_versionId = "3121199";</script> <script src="//contextual.media.net/dmedianet.js?cid=8CUVGXD58" async="async"></script> <script type="text/javascript">window._mNHandle = window._mNHandle || {};
		    window._mNHandle.queue = window._mNHandle.queue || [];
		    medianet_versionId = "3161199";
		        (function() {
		        var sct = document.createElement("script"),
		        winObj = window.top || window,
		        sctHl = winObj.document.getElementsByTagName("script")[0];
		        sct.type = "text/javascript";
		        sct.src = '//contextual.media.net/einslmedianet.js?cid=8CUVGXD58&crid=107532641&size=641x481';
		        sct.async = "async";
		        sctHl.parentNode.insertBefore(sct, sctHl);
		    })();</script> <script type="text/javascript">function getCookie(cname) {
        var name = cname + "=";
        var ca = document.cookie.split(';');
        for(var i = 0; i <ca.length; i++) {
            var c = ca[i];
            while (c.charAt(0)==' ') {
                c = c.substring(1);
            }
            if (c.indexOf(name) == 0) {
                return c.substring(name.length,c.length);
            }
        }
        return "";
    }
    var gdprcookie = getCookie('viewed_cookie_policy');</script> <script type="text/javascript">if( gdprcookie == 'yes' ) {
			Krux('ns:madavormedia', 'consent:set', {
			  dc: true,
			  al: true,
			  tg: true,
			  cd: true,
			  sh: true,
			  re: true
			}, function(errors, body) {
			  if (errors) {
			    console.error(errors);
			  } else {
			    console.log('Successfully accepted.');
			  }
			});
		} else {
			Krux('ns:madavormedia', 'consent:set', {
			  dc: false,
			  al: false,
			  tg: false,
			  cd: false,
			  sh: false,
			  re: false
			}, function(errors, body) {
			  if (errors) {
			    console.error(errors);
			  } else {
			    console.log('Successfully rejected.');
			  }
			});
		}</script> <script type="text/javascript">var cli_flush_cache=2;</script> <link rel="amphtml" href="https://www.diabetesselfmanagement.com/nutrition-exercise/exercise/choosing-right-fitness-program/?amp"><!-- Global site tag (gtag.js) - Google Analytics --> <script async src="https://www.googletagmanager.com/gtag/js?id=UA-52709200-2"></script> <script>window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-52709200-2');</script> <script>!function(g,s,q,r,d){r=g[r]=g[r]||function(){(r.q=r.q||[]).push(
  arguments)};d=s.createElement(q);q=s.getElementsByTagName(q)[0];
  d.src='//d1l6p2sc9645hc.cloudfront.net/tracker.js';q.parentNode.
  insertBefore(d,q)}(window,document,'script','_gs');

  _gs('GSN-908944-D');</script> <script type="text/javascript" src="https://10916430.collect.igodigital.com/collect.js"></script> <script type="text/javascript">_etmc.push(["setOrgId", "10916430"]);
_etmc.push(["trackPageView"]);</script> <!-- Start Quantcast tag --> <script type="text/javascript">_qoptions={
qacct:"p-17R6snYRbYYYg"
};</script> <script type="text/javascript" src="https://edge.quantserve.com/quant.js"></script> <noscript> <img src="https://pixel.quantserve.com/pixel/p-17R6snYRbYYYg.gif" style="display: none;" border="0" height="1" width="1" alt="Quantcast"/> </noscript> <!-- End Quantcast tag --> <!-- Begin comScore Tag --> <script>document.write(unescape("%3Cscript src='" + (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js' %3E%3C/script%3E"));</script> <script>COMSCORE.beacon({
    c1:2,
    c2:8053344,
    c3:"",
    c4:"",
    c5:"",
    c6:"",
    c15:""
  });</script> <noscript> <img src="http://b.scorecardresearch.com/p?c1=2&c2=8053344&c3=&c4=&c5=&c6=&c15=&cj=1" /> </noscript> <!-- End comScore Tag --><!--[if lt IE 9]> <script src="//html5shiv.googlecode.com/svn/trunk/html5.js"></script> <![endif]--> <!-- Global site tag (gtag.js) - Google Ads: 1054471301 --> <script async src="https://www.googletagmanager.com/gtag/js?id=AW-1054471301"></script> <script>window.dataLayer = window.dataLayer || [];
	 function gtag(){dataLayer.push(arguments);}
	 gtag('js', new Date());

	 gtag('config', 'AW-1054471301');</script> <script data-cfasync="false" id="ao_optimized_gfonts_webfontloader" type="text/javascript">(function() {var wf = document.createElement('script');wf.src='https://ajax.googleapis.com/ajax/libs/webfont/1/webfont.js';wf.type='text/javascript';wf.async='true';var s=document.getElementsByTagName('script')[0];s.parentNode.insertBefore(wf, s);})();</script></head><body class="nutrition_exercise-template-default single single-nutrition_exercise postid-43653 desktop gecko"><div id="page" class="hfeed site"> <a class="skip-link screen-reader-text" href="#content">Skip to content</a><header id="masthead" class="site-header" role="banner" style="margin-bottom: 0;"><div class="wrapper"><div class="site-header__branding"><div class="site-header__site-title"><a href="https://www.diabetesselfmanagement.com/" rel="home"><noscript><img alt="Diabetes Self-Management" src="https://www.diabetesselfmanagement.com/wp-content/themes/dsmrefresh/images/logo2x.png" title="Diabetes Self-Management" width="270" /></noscript><img class="lazyload" alt="Diabetes Self-Management" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20270%20%22%3E%3C/svg%3E' data-src="https://www.diabetesselfmanagement.com/wp-content/themes/dsmrefresh/images/logo2x.png" title="Diabetes Self-Management" width="270" /></a></div></div><!-- .site-branding --><div class="site-header__utility"><div class="site-header__social"><ul class="social-nav"><li class="social-nav__item social-nav__facebook"><a class="icon icon-facebook-circled" href="https://www.facebook.com/DiabetesSelfManagement" target="_blank"><span class="screen-reader-text">Facebook</span></a></li><li class="social-nav__item social-nav__twitter"><a class="icon icon-twitter-circled" href="https://twitter.com/ManageDiabetes" target="_blank"><span class="screen-reader-text">Twitter</span></a></li><li class="social-nav__item social-nav__pinterest"><a class="icon icon-pinterest" href="https://www.pinterest.com/diabetesrecipes/" target="_blank"><span class="screen-reader-text">Pinterest</span></a></li></ul></div><div class="site-header__mobile-controls" id="mobile-toggles"> <button class="btn-mbl toggler search-toggle" id="search-toggle" aria-controls="search" aria-expanded="false"><i class="icon-search"></i><span class="screen-reader-text">Search</span></button> <button class="btn-mbl toggler menu-toggle" id="menu-toggle" aria-controls="menu" aria-expanded="false"><i class="icon-menu"></i><span class="screen-reader-text">Menu</span></button></div><div class="site-header__newsstand"> <a href="/subscribe/"><noscript><img src="https://www.diabetesselfmanagement.com/wp-content/themes/dsmrefresh/images/on-newsstands.png" alt"Subscribe to Diabetes Self-Management"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20%20%22%3E%3C/svg%3E' data-src="https://www.diabetesselfmanagement.com/wp-content/themes/dsmrefresh/images/on-newsstands.png" alt"Subscribe to Diabetes Self-Management"></a></div><div class="site-header__subscribe"><a class="btn btn--a" style="padding: 8px 25px;" href="/subscribe/">Subscribe</a></div><div class="site-header__search" id="site-search"><form role="search" method="get" class="search-form" action="https://www.diabetesselfmanagement.com/" id="search-form"> <label> <span class="screen-reader-text">Search for:</span> <input type="search" class="search-field" placeholder="Search" value="" name="s" title="Search for:" /> </label> <input type="submit" class="search-submit" value="GO" /> <span class="searchbox-icon"></span></form></div></div></div><nav id="site-navigation" class="site-header__main-navigation" role="navigation"><div class="menu-primary-container"><ul id="menu-primary" class="menu"><li id="menu-item-127" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-127"><a href="https://www.diabetesselfmanagement.com/about-diabetes/">About Diabetes</a><ul class="sub-menu"><li id="menu-item-122" class="menu-item menu-item-type-taxonomy menu-item-object-about_diabetes_cat menu-item-122"><a href="https://www.diabetesselfmanagement.com/about-diabetes/types-of-diabetes/">Types Symptoms of Diabetes</a></li><li id="menu-item-119" class="menu-item menu-item-type-taxonomy menu-item-object-about_diabetes_cat menu-item-119"><a href="https://www.diabetesselfmanagement.com/about-diabetes/diabetes-basics/">Diabetes Basics: Information for Beginners</a></li><li id="menu-item-121" class="menu-item menu-item-type-taxonomy menu-item-object-about_diabetes_cat menu-item-121"><a href="https://www.diabetesselfmanagement.com/about-diabetes/diabetes-kids/">Kids &#038; Diabetes</a></li><li id="menu-item-120" class="menu-item menu-item-type-taxonomy menu-item-object-about_diabetes_cat menu-item-120"><a href="https://www.diabetesselfmanagement.com/about-diabetes/general-diabetes-information/">General Diabetes Information</a></li></ul></li><li id="menu-item-128" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-128"><a href="https://www.diabetesselfmanagement.com/managing-diabetes/">Managing Diabetes</a><ul class="sub-menu"><li id="menu-item-109" class="menu-item menu-item-type-taxonomy menu-item-object-managing_diabetes_cat menu-item-109"><a href="https://www.diabetesselfmanagement.com/managing-diabetes/blood-glucose-management/">Diabetes Blood Glucose Management</a></li><li id="menu-item-114" class="menu-item menu-item-type-taxonomy menu-item-object-managing_diabetes_cat menu-item-114"><a href="https://www.diabetesselfmanagement.com/managing-diabetes/treatment-approaches/">Diabetes Treatment &#038; Therapy</a></li><li id="menu-item-110" class="menu-item menu-item-type-taxonomy menu-item-object-managing_diabetes_cat menu-item-110"><a href="https://www.diabetesselfmanagement.com/managing-diabetes/complications-prevention/">Complications &#038; Prevention</a></li><li id="menu-item-115" class="menu-item menu-item-type-taxonomy menu-item-object-managing_diabetes_cat menu-item-115"><a href="https://www.diabetesselfmanagement.com/managing-diabetes/womens-health/">Women&#8217;s Health</a></li><li id="menu-item-111" class="menu-item menu-item-type-taxonomy menu-item-object-managing_diabetes_cat menu-item-111"><a href="https://www.diabetesselfmanagement.com/managing-diabetes/emotional-health/">Emotional Effects of Diabetes</a></li><li id="menu-item-112" class="menu-item menu-item-type-taxonomy menu-item-object-managing_diabetes_cat menu-item-112"><a href="https://www.diabetesselfmanagement.com/managing-diabetes/general-health-issues/">General Diabetes Health Issues</a></li><li id="menu-item-113" class="menu-item menu-item-type-taxonomy menu-item-object-managing_diabetes_cat menu-item-113"><a href="https://www.diabetesselfmanagement.com/managing-diabetes/getting-to-know-you/">Living With Diabetes: Getting To Know You</a></li></ul></li><li id="menu-item-129" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-129"><a href="https://www.diabetesselfmanagement.com/recipes/">Diabetes Recipes</a><ul class="sub-menu"><li id="menu-item-132" class="menu-item menu-item-type-taxonomy menu-item-object-meal_type menu-item-132"><a href="https://www.diabetesselfmanagement.com/recipes/beverages/">Diabetic Drinks &#038; Beverages</a></li><li id="menu-item-133" class="menu-item menu-item-type-taxonomy menu-item-object-meal_type menu-item-133"><a href="https://www.diabetesselfmanagement.com/recipes/breakfast/">Diabetic Breakfast Recipes</a></li><li id="menu-item-134" class="menu-item menu-item-type-taxonomy menu-item-object-meal_type menu-item-134"><a href="https://www.diabetesselfmanagement.com/recipes/desserts-sweets/">Desserts &#038; Sweets</a></li><li id="menu-item-135" class="menu-item menu-item-type-taxonomy menu-item-object-meal_type menu-item-135"><a href="https://www.diabetesselfmanagement.com/recipes/main-dishes/">Diabetic Dinner Recipes</a></li><li id="menu-item-136" class="menu-item menu-item-type-taxonomy menu-item-object-meal_type menu-item-136"><a href="https://www.diabetesselfmanagement.com/recipes/salads/">Salad Recipes for Diabetics</a></li><li id="menu-item-137" class="menu-item menu-item-type-taxonomy menu-item-object-meal_type menu-item-137"><a href="https://www.diabetesselfmanagement.com/recipes/sides/">Diabetic Side Dish Recipes</a></li><li id="menu-item-138" class="menu-item menu-item-type-taxonomy menu-item-object-meal_type menu-item-138"><a href="https://www.diabetesselfmanagement.com/recipes/snacks-appetizers/">Snacks &#038; Appetizers</a></li><li id="menu-item-139" class="menu-item menu-item-type-taxonomy menu-item-object-meal_type menu-item-139"><a href="https://www.diabetesselfmanagement.com/recipes/soups-stews/">Soups &#038; Stews</a></li></ul></li><li id="menu-item-130" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-130"><a href="https://www.diabetesselfmanagement.com/nutrition-exercise/">Nutrition &#038; Exercise</a><ul class="sub-menu"><li id="menu-item-123" class="menu-item menu-item-type-taxonomy menu-item-object-nutrition_exercise_cat menu-item-123"><a href="https://www.diabetesselfmanagement.com/nutrition-exercise/exercise/">Exercise</a></li><li id="menu-item-124" class="menu-item menu-item-type-taxonomy menu-item-object-nutrition_exercise_cat menu-item-124"><a href="https://www.diabetesselfmanagement.com/nutrition-exercise/meal-planning/">Diabetic Meal &#038; Food Planning</a></li><li id="menu-item-126" class="menu-item menu-item-type-taxonomy menu-item-object-nutrition_exercise_cat menu-item-126"><a href="https://www.diabetesselfmanagement.com/nutrition-exercise/weight-loss-management/">Weight Loss &#038; Management</a></li><li id="menu-item-125" class="menu-item menu-item-type-taxonomy menu-item-object-nutrition_exercise_cat menu-item-125"><a href="https://www.diabetesselfmanagement.com/nutrition-exercise/nutrition/">Nutrition &#038; Diabetes</a></li></ul></li><li id="menu-item-131" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-131"><a href="https://www.diabetesselfmanagement.com/diabetes-resources/">Diabetes Resources</a><ul class="sub-menu"><li id="menu-item-40872" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-40872"><a href="https://www.diabetesselfmanagement.com/type-1-diabetes-videos/">Type 1 Diabetes Videos</a></li><li id="menu-item-20830" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-20830"><a href="https://www.diabetesselfmanagement.com/videos/">Diabetes Videos</a></li><li id="menu-item-116" class="menu-item menu-item-type-taxonomy menu-item-object-diabetes_resource_cat menu-item-116"><a href="https://www.diabetesselfmanagement.com/diabetes-resources/definitions/">Type 1 &#038; Type 2 Diabetes Definitions</a></li><li id="menu-item-41450" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-41450"><a href="https://www.diabetesselfmanagement.com/tips/">Diabetes Tips</a></li><li id="menu-item-41449" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-41449"><a href="https://www.diabetesselfmanagement.com/type-1-diabetes-tips/">Type 1 Diabetes Tips</a></li><li id="menu-item-117" class="menu-item menu-item-type-taxonomy menu-item-object-diabetes_resource_cat menu-item-117"><a href="https://www.diabetesselfmanagement.com/diabetes-resources/money-matters/">Money Matters</a></li><li id="menu-item-118" class="menu-item menu-item-type-taxonomy menu-item-object-diabetes_resource_cat menu-item-118"><a href="https://www.diabetesselfmanagement.com/diabetes-resources/tools-tech/">Tools &#038; Tech</a></li><li id="menu-item-33834" class="menu-item-pdb menu-item menu-item-type-custom menu-item-object-custom menu-item-33834"><a href="https://www.diabetesselfmanagement.com/practical-diabetology/">Clinician Resources</a></li></ul></li><li id="menu-item-1261" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1261"><a href="https://www.diabetesselfmanagement.com/blog/">Blog</a></li></ul></div></nav><!-- #site-navigation --></header><!-- #masthead --><div class="ad-header" style="margin: 10px; background-color: transparent;"><div class="txt-c"><div class="ad ad--leaderboard"><div class="txt-c ad__heading screen-reader-text"><small>Advertisement</small></div><div id="div-ad-leaderboarda"> <script type="text/javascript">googletag.display('div-ad-leaderboarda');</script> </div></div></div></div><div id="content" class="site-content"><div class="wrapper"><div id="primary" class="content-area"><main id="main" class="site-main" role="main"><div class="page-links breadcrumbs" xmlns:v="http://rdf.data-vocabulary.org/#"> <!-- Breadcrumb NavXT 6.3.0 --> <span typeof="v:Breadcrumb"><a rel="v:url" property="v:title" title="Go to Diabetes Self-Management." href="https://www.diabetesselfmanagement.com" class="home">Home</a></span><span class="breadcrumb-carot" aria-hidden="true"></span><span typeof="v:Breadcrumb"><a rel="v:url" property="v:title" title="Go to Nutrition &amp; Exercise ." href="https://www.diabetesselfmanagement.com/nutrition-exercise/">Nutrition & Exercise </a></span><span class="breadcrumb-carot" aria-hidden="true"></span><span typeof="v:Breadcrumb"><a rel="v:url" property="v:title" title="Go to the Exercise Nutrition &amp; Exercise Category archives." href="https://www.diabetesselfmanagement.com/nutrition-exercise/exercise/">Exercise</a></span><span class="breadcrumb-carot" aria-hidden="true"></span><span typeof="v:Breadcrumb"><a rel="v:url" property="v:title" title="Go to Choosing the Right Fitness Program for You." href="https://www.diabetesselfmanagement.com/nutrition-exercise/exercise/choosing-right-fitness-program/">Choosing the Right Fitness Program for You</a></span></div><article id="post-43653" class="current-article post-43653 nutrition_exercise type-nutrition_exercise status-publish has-post-thumbnail hentry nutrition_exercise_cat-exercise iab_categories-fitness-and-exercise iab_categories-medical-health iab_categories-running-and-jogging topics-aerobic-exercise topics-bariatrics topics-body-shape topics-clinical-medicine topics-determinants-of-health topics-dieting topics-eating-behaviors-of-humans topics-exercise topics-health topics-health-care topics-health-education topics-health-promotion topics-high-intensity-interval-training topics-hobbies topics-human-activities topics-human-weight topics-hyperalimentation topics-management-of-obesity topics-medical-specialties topics-medical-treatments topics-metabolic-disorders topics-nutrition topics-obesity topics-physical-exercise topics-physical-fitness topics-public-health topics-recreation topics-self-care topics-sports topics-strength-training topics-weight-loss"><header class="entry-header"><h1 class="entry-title header-bottom-border">Choosing the Right Fitness Program for You</header><!-- .entry-header --><div class="entry-meta col palm-one-whole lap-one-half desk-one-half"> <span class="posted-on"><span class="byline" style="display: contents;">By <span class="author vcard"><span class="fn">Nicola Davies, PhD</span></span><br /></span><time class="entry-date updated published" datetime="2020-01-02T08:00:16-05:00">Published January 2, 2020</time></span><br /></div><!-- .entry-meta --><div class="featured-image"> <noscript><img width="640" height="427" src="https://cdn.diabetesselfmanagement.com/2019/12/shutterstock_310054760.jpg" class="attachment-large size-large wp-post-image" alt="Choosing the Right Fitness Program for You" title="Choosing the Right Fitness Program for You" srcset="//cdn.diabetesselfmanagement.com/2019/12/shutterstock_310054760.jpg 1000w, //cdn.diabetesselfmanagement.com/2019/12/shutterstock_310054760-300x200.jpg 300w, //cdn.diabetesselfmanagement.com/2019/12/shutterstock_310054760-768x512.jpg 768w" sizes="(max-width: 640px) 100vw, 640px" /></noscript><img width="640" height="427" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20640%20427%22%3E%3C/svg%3E' data-src="https://cdn.diabetesselfmanagement.com/2019/12/shutterstock_310054760.jpg" class="lazyload attachment-large size-large wp-post-image" alt="Choosing the Right Fitness Program for You" title="Choosing the Right Fitness Program for You" data-srcset="//cdn.diabetesselfmanagement.com/2019/12/shutterstock_310054760.jpg 1000w, //cdn.diabetesselfmanagement.com/2019/12/shutterstock_310054760-300x200.jpg 300w, //cdn.diabetesselfmanagement.com/2019/12/shutterstock_310054760-768x512.jpg 768w" data-sizes="(max-width: 640px) 100vw, 640px" /></div><div style="float: right; display: inline-block; vertical-align: middle;" class="addthis_inline_share_toolbox_a2zf"></div></h1><div class="clearfix"><div class="utility_links palm-one-whole lap-one-half desk-one-half"> <a class="print_link" href="https://www.diabetesselfmanagement.com/nutrition-exercise/exercise/choosing-right-fitness-program/?print=0"><i class="icon-print"></i> Print</a> <span class="text-size-adjust"> <span class="text-size-adjust_heading">Text Size:</span> <a class="text-size-adjust_control text-size-adjust_small" href="#nogo">A</a> <a class="text-size-adjust_control text-size-adjust_medium" href="#nogo">A</a> <a class="text-size-adjust_control text-size-adjust_large" href="#nogo">A</a> </span></div></div><div class="entry-content"><p>To maintain a <a href="https://www.diabetesselfmanagement.com/nutrition-exercise/weight-loss-management/">healthy weight</a>, you need to work on your fitness. This will require a concerted effort to integrate exercise into your daily schedule — no matter how busy you are. The first place to start is choosing the best exercise for you and your needs.</p><div class="alignleft"><div class="ad ad--skyscraper"><div class="txt-c ad__heading" style="margin-top: 0"><small>Advertisement</small></div><div id="div-ad-skyscrapera"> <script type="text/javascript">googletag.display('div-ad-skyscrapera');</script> </div></div></div><h2>Does personality matter?</h2><p>According to fitness coach Eric Stevens, the key to finding the right fitness program is to match it to your personality.</p><p>Are you an extrovert — outgoing and socially confident? You are likely to enjoy high-energy exercises such as <a href="https://www.diabetesselfmanagement.com/nutrition-exercise/exercise/zumba-for-diabetes/">Zumba</a> and high-intensity interval training (HIIT), team sports and social get-togethers like group <a href="https://www.diabetesselfmanagement.com/nutrition-exercise/exercise/hiking-for-health/">hikes</a>.</p><p><em><strong>To get cutting-edge diabetes news, strategies for blood glucose management, nutrition tips, healthy recipes, and more delivered straight to your inbox, <a href="https://www.diabetesselfmanagement.com/newsletter/">sign up for our free newsletter</a>!</strong></em></p><p>Are you an introvert who is more focused on your internal world? Quieter physical activity might be more for you, including activities that allow you to clear your head, such as mind–body disciplines (<a href="https://www.diabetesselfmanagement.com/blog/yoga-for-diabetes/">yoga</a> and Pilates), countryside walks, <a href="https://www.diabetesselfmanagement.com/nutrition-exercise/exercise/teeing-up-for-a-healthy-heart/">golf</a> and endurance sports (<a href="https://www.diabetesselfmanagement.com/nutrition-exercise/exercise/biking-101/">cycling</a>, swimming and running).</p><h2>Developing a balanced fitness plan</h2><p><a href="https://www.hhs.gov/fitness/be-active/physical-activity-guidelines-for-americans/index.html" target="_blank" rel="noopener noreferrer">According to the U.S. Department of Health and Human Services (HHS)</a>, your weekly exercise routine should include 150 minutes of moderate aerobic exercise or 75 minutes of vigorous aerobic activity. If this level of exercise seems daunting, start slowly and increase gradually. For instance, you could start with one 10-minute <a href="https://www.diabetesselfmanagement.com/nutrition-exercise/exercise/health-benefits-of-walking/">walk</a> five days a week, moving up to two 10-minutes walks, and then three 10-minute walks. This would eventually amount to 150 minutes of walking each week via achievable, bite-size sessions.</p><p>It is also advisable to include at least two weekly strength-training sessions in your routine. Building muscle really is a win-win situation since you will burn calories while you train, but muscle also increases your fat-burning ability while at rest. If you get into strength training, ensure you have a minimum of 48 hours of rest between sessions to let your muscles recover.</p><h2>Making time for fitness</h2><p>Your time is an important asset when trying to make exercise a habit. However, exercise doesn’t have to be time-consuming to be effective. In other words, you can plan your exercise routine around your schedule — even integrating it into your journey to work or your time with friends. Meeting a friend for coffee? Why not find a location where you can chat over your drinks and finish with a walk? Or maybe you could go for a swim and then finish with a healthy lunch together? If you want to integrate fitness into your life, you can make it work without having to disrupt your usual daily activities.</p><div class="medianet-desktop-outer-box"><div class="medianet-desktop-inner-box"><div id="medianet_diabetesselfmanagement_desktop"></div></div></div><h2>Fitness really does matter</h2><p>While diet or physical activity alone may help you either lose or maintain weight, a combination of the two will propel you to your goals faster. <a href="https://www.ncbi.nlm.nih.gov/pmc/articles/PMC5552187/" target="_blank" rel="noopener noreferrer">In one study</a> that included 40 women with overweight or obesity, four groups were formed: resistance training only, diet only, resistance training plus diet, and a control group (a non-intervention group). At the end of the study, all three intervention groups showed a decrease in fat mass, but the largest decrease was recorded for the resistance training plus diet group.</p><p>So, are you ready to commit? Tell at least one person your fitness plans, as spreading the word will help make it a reality. You’ve got this!</p><p><em><strong>Want to learn more about exercising with diabetes? Read <a href="https://www.diabetesselfmanagement.com/nutrition-exercise/exercise/add-movement-life/">&#8220;Add Movement to Your Life,&#8221;</a> <a href="https://www.diabetesselfmanagement.com/nutrition-exercise/exercise/picking-the-right-activity-to-meet-your-fitness-goals/">&#8220;Picking the Right Activity to Meet Your Fitness Goals&#8221;</a> and <a href="https://www.diabetesselfmanagement.com/nutrition-exercise/exercise/seven-ways-have-fun-exercising/">&#8220;Seven Ways to Have Fun Exercising.&#8221;</a> </strong></em></p><div class="" style="
 padding: 10px;
 border-top: 1px solid #f1f1f1;  "><p>Learn more about the health and medical experts who who provide you with the cutting-edge resources, tools, news, and more on Diabetes Self-Management.<br /><a class="btn btn--a" href="/about-our-expert-authors/">About Our Experts &gt;&gt;</a></p></div></div><!-- .entry-content --> <!-- RELATED ARTICLES --><div class="ra-main-wrapper"><header class="home-feature-header"><h2 class="home-feature-header_heading">Related Articles</h2></header><div class="clearfix"><div class="ra-article-row"><div class="ra-article-wrapper"><article id="post-41480" class="post-41480 ra-article_article"><div> <a href="https://www.diabetesselfmanagement.com/nutrition-exercise/exercise/exercises-improve-digestion/"><noscript><img width="640" height="436" src="https://cdn.diabetesselfmanagement.com/2019/08/Take-5.png" class="ra-image-w ra-image-h wp-post-image" alt="Exercises to Improve Digestion" title="Exercises to Improve Digestion" srcset="//cdn.diabetesselfmanagement.com/2019/08/Take-5.png 704w, //cdn.diabetesselfmanagement.com/2019/08/Take-5-300x205.png 300w" sizes="(max-width: 640px) 100vw, 640px" /></noscript><img width="640" height="436" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20640%20436%22%3E%3C/svg%3E' data-src="https://cdn.diabetesselfmanagement.com/2019/08/Take-5.png" class="lazyload ra-image-w ra-image-h wp-post-image" alt="Exercises to Improve Digestion" title="Exercises to Improve Digestion" data-srcset="//cdn.diabetesselfmanagement.com/2019/08/Take-5.png 704w, //cdn.diabetesselfmanagement.com/2019/08/Take-5-300x205.png 300w" data-sizes="(max-width: 640px) 100vw, 640px" /></a></div><div class="ra-title-wrapper ra-image-w"><header><a href="https://www.diabetesselfmanagement.com/nutrition-exercise/exercise/exercises-improve-digestion/" rel="bookmark" class="ra-title-link">Exercises to Improve Digestion</a></header></div></article></div><div class="ra-article-wrapper"><article id="post-42494" class="post-42494 ra-article_article"><div> <a href="https://www.diabetesselfmanagement.com/nutrition-exercise/exercise/home-gym-budget/"><noscript><img width="640" height="429" src="https://cdn.diabetesselfmanagement.com/2019/09/shutterstock_1254375040-1024x687.jpg" class="ra-image-w ra-image-h wp-post-image" alt="Home Gym on a Budget" title="Home Gym on a Budget" srcset="//cdn.diabetesselfmanagement.com/2019/09/shutterstock_1254375040-1024x687.jpg 1024w, //cdn.diabetesselfmanagement.com/2019/09/shutterstock_1254375040-300x201.jpg 300w, //cdn.diabetesselfmanagement.com/2019/09/shutterstock_1254375040-768x515.jpg 768w" sizes="(max-width: 640px) 100vw, 640px" /></noscript><img width="640" height="429" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20640%20429%22%3E%3C/svg%3E' data-src="https://cdn.diabetesselfmanagement.com/2019/09/shutterstock_1254375040-1024x687.jpg" class="lazyload ra-image-w ra-image-h wp-post-image" alt="Home Gym on a Budget" title="Home Gym on a Budget" data-srcset="//cdn.diabetesselfmanagement.com/2019/09/shutterstock_1254375040-1024x687.jpg 1024w, //cdn.diabetesselfmanagement.com/2019/09/shutterstock_1254375040-300x201.jpg 300w, //cdn.diabetesselfmanagement.com/2019/09/shutterstock_1254375040-768x515.jpg 768w" data-sizes="(max-width: 640px) 100vw, 640px" /></a></div><div class="ra-title-wrapper ra-image-w"><header><a href="https://www.diabetesselfmanagement.com/nutrition-exercise/exercise/home-gym-budget/" rel="bookmark" class="ra-title-link">Home Gym on a Budget</a></header></div></article></div><div class="ra-article-wrapper"><article id="post-40320" class="post-40320 ra-article_article"><div> <a href="https://www.diabetesselfmanagement.com/nutrition-exercise/exercise/zumba-for-diabetes/"><noscript><img width="640" height="427" src="https://cdn.diabetesselfmanagement.com/2019/06/shutterstock_277628426.jpg" class="ra-image-w ra-image-h wp-post-image" alt="Zumba for Diabetes" title="Zumba for Diabetes" srcset="//cdn.diabetesselfmanagement.com/2019/06/shutterstock_277628426.jpg 1000w, //cdn.diabetesselfmanagement.com/2019/06/shutterstock_277628426-300x200.jpg 300w, //cdn.diabetesselfmanagement.com/2019/06/shutterstock_277628426-768x512.jpg 768w" sizes="(max-width: 640px) 100vw, 640px" /></noscript><img width="640" height="427" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20640%20427%22%3E%3C/svg%3E' data-src="https://cdn.diabetesselfmanagement.com/2019/06/shutterstock_277628426.jpg" class="lazyload ra-image-w ra-image-h wp-post-image" alt="Zumba for Diabetes" title="Zumba for Diabetes" data-srcset="//cdn.diabetesselfmanagement.com/2019/06/shutterstock_277628426.jpg 1000w, //cdn.diabetesselfmanagement.com/2019/06/shutterstock_277628426-300x200.jpg 300w, //cdn.diabetesselfmanagement.com/2019/06/shutterstock_277628426-768x512.jpg 768w" data-sizes="(max-width: 640px) 100vw, 640px" /></a></div><div class="ra-title-wrapper ra-image-w"><header><a href="https://www.diabetesselfmanagement.com/nutrition-exercise/exercise/zumba-for-diabetes/" rel="bookmark" class="ra-title-link">Zumba for Diabetes</a></header></div></article></div></div><div class="ra-article-row"><div class="ra-article-wrapper"><article id="post-40237" class="post-40237 ra-article_article"><div> <a href="https://www.diabetesselfmanagement.com/nutrition-exercise/exercise/three-easy-office-exercises/"><noscript><img width="640" height="480" src="https://cdn.diabetesselfmanagement.com/2019/06/shutterstock_308860676.jpg" class="ra-image-w ra-image-h wp-post-image" alt="Three Easy Office Exercises" title="Three Easy Office Exercises" srcset="//cdn.diabetesselfmanagement.com/2019/06/shutterstock_308860676.jpg 1000w, //cdn.diabetesselfmanagement.com/2019/06/shutterstock_308860676-300x225.jpg 300w, //cdn.diabetesselfmanagement.com/2019/06/shutterstock_308860676-768x576.jpg 768w" sizes="(max-width: 640px) 100vw, 640px" /></noscript><img width="640" height="480" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20640%20480%22%3E%3C/svg%3E' data-src="https://cdn.diabetesselfmanagement.com/2019/06/shutterstock_308860676.jpg" class="lazyload ra-image-w ra-image-h wp-post-image" alt="Three Easy Office Exercises" title="Three Easy Office Exercises" data-srcset="//cdn.diabetesselfmanagement.com/2019/06/shutterstock_308860676.jpg 1000w, //cdn.diabetesselfmanagement.com/2019/06/shutterstock_308860676-300x225.jpg 300w, //cdn.diabetesselfmanagement.com/2019/06/shutterstock_308860676-768x576.jpg 768w" data-sizes="(max-width: 640px) 100vw, 640px" /></a></div><div class="ra-title-wrapper ra-image-w"><header><a href="https://www.diabetesselfmanagement.com/nutrition-exercise/exercise/three-easy-office-exercises/" rel="bookmark" class="ra-title-link">Three Easy Office Exercises</a></header></div></article></div><div class="ra-article-wrapper"><article id="post-41941" class="post-41941 ra-article_article"><div> <a href="https://www.diabetesselfmanagement.com/nutrition-exercise/exercise/diabetes-kickboxing/"><noscript><img width="640" height="459" src="https://cdn.diabetesselfmanagement.com/2019/08/shutterstock_785627554-1024x734.jpg" class="ra-image-w ra-image-h wp-post-image" alt="Diabetes and Kickboxing" title="Diabetes and Kickboxing" srcset="//cdn.diabetesselfmanagement.com/2019/08/shutterstock_785627554-1024x734.jpg 1024w, //cdn.diabetesselfmanagement.com/2019/08/shutterstock_785627554-300x215.jpg 300w, //cdn.diabetesselfmanagement.com/2019/08/shutterstock_785627554-768x550.jpg 768w" sizes="(max-width: 640px) 100vw, 640px" /></noscript><img width="640" height="459" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20640%20459%22%3E%3C/svg%3E' data-src="https://cdn.diabetesselfmanagement.com/2019/08/shutterstock_785627554-1024x734.jpg" class="lazyload ra-image-w ra-image-h wp-post-image" alt="Diabetes and Kickboxing" title="Diabetes and Kickboxing" data-srcset="//cdn.diabetesselfmanagement.com/2019/08/shutterstock_785627554-1024x734.jpg 1024w, //cdn.diabetesselfmanagement.com/2019/08/shutterstock_785627554-300x215.jpg 300w, //cdn.diabetesselfmanagement.com/2019/08/shutterstock_785627554-768x550.jpg 768w" data-sizes="(max-width: 640px) 100vw, 640px" /></a></div><div class="ra-title-wrapper ra-image-w"><header><a href="https://www.diabetesselfmanagement.com/nutrition-exercise/exercise/diabetes-kickboxing/" rel="bookmark" class="ra-title-link">Diabetes and Kickboxing</a></header></div></article></div><div class="ra-article-wrapper"><article id="post-41704" class="post-41704 ra-article_article"><div> <a href="https://www.diabetesselfmanagement.com/nutrition-exercise/exercise/seven-ways-have-fun-exercising/"><noscript><img width="640" height="427" src="https://cdn.diabetesselfmanagement.com/2019/08/shutterstock_1090948673.jpg" class="ra-image-w ra-image-h wp-post-image" alt="Seven Ways to Have Fun Exercising" title="Seven Ways to Have Fun Exercising" srcset="//cdn.diabetesselfmanagement.com/2019/08/shutterstock_1090948673.jpg 1000w, //cdn.diabetesselfmanagement.com/2019/08/shutterstock_1090948673-300x200.jpg 300w, //cdn.diabetesselfmanagement.com/2019/08/shutterstock_1090948673-768x512.jpg 768w" sizes="(max-width: 640px) 100vw, 640px" /></noscript><img width="640" height="427" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20640%20427%22%3E%3C/svg%3E' data-src="https://cdn.diabetesselfmanagement.com/2019/08/shutterstock_1090948673.jpg" class="lazyload ra-image-w ra-image-h wp-post-image" alt="Seven Ways to Have Fun Exercising" title="Seven Ways to Have Fun Exercising" data-srcset="//cdn.diabetesselfmanagement.com/2019/08/shutterstock_1090948673.jpg 1000w, //cdn.diabetesselfmanagement.com/2019/08/shutterstock_1090948673-300x200.jpg 300w, //cdn.diabetesselfmanagement.com/2019/08/shutterstock_1090948673-768x512.jpg 768w" data-sizes="(max-width: 640px) 100vw, 640px" /></a></div><div class="ra-title-wrapper ra-image-w"><header><a href="https://www.diabetesselfmanagement.com/nutrition-exercise/exercise/seven-ways-have-fun-exercising/" rel="bookmark" class="ra-title-link">Seven Ways to Have Fun Exercising</a></header></div></article></div></div></div></div><div id="800355186"> <script type="text/javascript">try {
	            window._mNHandle.queue.push(function () {
	                window._mNDetails.loadTag("800355186", "1022x500", "800355186");
	            });
	        }
	        catch (error) {
	        }</script> </div><footer class="entry-footer"><div class="entry-footer__share"><div style="display: inline-block; vertical-align: middle;" class="addthis_inline_share_toolbox"></div></div><div class="entry-footer__author-details"><h2><a href="//cdn.diabetesselfmanagement.com/2018/09/Nicola-Pic-2.jpg"><noscript><img class="alignleft wp-image-35416 size-thumbnail" src="//cdn.diabetesselfmanagement.com/2018/09/Nicola-Pic-2-150x150.jpg" alt="Nicola Davies" width="150" height="150" srcset="//cdn.diabetesselfmanagement.com/2018/09/Nicola-Pic-2-150x150.jpg 150w, //cdn.diabetesselfmanagement.com/2018/09/Nicola-Pic-2-200x200.jpg 200w, //cdn.diabetesselfmanagement.com/2018/09/Nicola-Pic-2-190x190.jpg 190w" sizes="(max-width: 150px) 100vw, 150px" /></noscript><img class="lazyload alignleft wp-image-35416 size-thumbnail" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20150%20150%22%3E%3C/svg%3E' data-src="//cdn.diabetesselfmanagement.com/2018/09/Nicola-Pic-2-150x150.jpg" alt="Nicola Davies" width="150" height="150" data-srcset="//cdn.diabetesselfmanagement.com/2018/09/Nicola-Pic-2-150x150.jpg 150w, //cdn.diabetesselfmanagement.com/2018/09/Nicola-Pic-2-200x200.jpg 200w, //cdn.diabetesselfmanagement.com/2018/09/Nicola-Pic-2-190x190.jpg 190w" data-sizes="(max-width: 150px) 100vw, 150px" /></a><a href="http://www.trustedwriter.com" target="_blank" rel="noopener noreferrer">Nicola Davies, BSc, Hons, MSc Comm, PhD, DipC, MBACP, MBPsS, NUJ</a></h2><p>Davies is a Health Psychologist and Medical Writer at Health Psychology Consultancy Ltd. Her expertise is in the psychology of health and well-being, which she writes prolifically on across the globe. She has three books: <em>I Can Beat Obesity! Finding the Motivation, Confidence and Skills to Lose Weight and Avoid Relapse, I Can Beat Anorexia! Finding the Motivation, Confidence and Skills to Recover and Avoid Relapse, </em>and <em>Eating Disorder Recovery Handbook: A Practical Guide to Long-Term Recovery.</em></p><p>Davies’ work in the field of pain is largely focused on lifestyle, behavior change, coping, and developing the skills and confidence to self-manage.</p><p><strong>Learn more about Nicola Davies:</strong></p><p><a href="http://trustedwriter.com/" target="_blank" rel="noopener noreferrer">Professional website</a> • <a href="https://www.linkedin.com/in/drnicoladavies" target="_blank" rel="noopener noreferrer">LinkedIn</a> • <a href="https://www.facebook.com/HPC-Ltd-307826779257582/" target="_blank" rel="noopener noreferrer">Facebook</a> • <a href="https://twitter.com/healthpsychuk" target="_blank" rel="noopener noreferrer">Twitter</a> • <a href="https://healthpsychologyconsultancy.wordpress.com/about/" target="_blank" rel="noopener noreferrer">Blog </a></p></div><div class="entry-footer__disclaimer"><p>Disclaimer Statements: Statements and opinions expressed on this Web site are those of the authors and not necessarily those of the publishers or advertisers. The information provided on this Web site should not be construed as medical instruction. Consult appropriate health-care professionals before taking action based on this information.</p></div></footer><!-- .entry-footer --></article><!-- #post-## --></main><!-- #main --></div><!-- #primary --><div id="secondary" class="widget-area" role="complementary"><div class="col-wrap clearfix"><div class="col palm-one-whole lap-one-half desk-one-whole"><div class="widget widget--ad widget--ad-1 txt-c"><div class="ad ad--box"><div class="txt-c ad__heading"><small>Advertisement</small></div><div id="div-ad-boxa"> <script type="text/javascript">googletag.display('div-ad-boxa');</script> </div></div></div></div><div class="col palm-one-whole lap-one-half desk-one-whole"><div class="widget widget--related-articles"><div class="callout--space"><h3 class="widget-title">Related Articles</h3><div class="widget-content"><ul class="ul-divided"><li><a href="https://www.diabetesselfmanagement.com/nutrition-exercise/exercise/considerations-exercising-type-1-diabetes/" onclick="dataLayer.push({'event':'GAevent','eventCategory': 'Related Articles', 'eventAction': 'Click-Desktop', 'eventLabel':'https://www.diabetesselfmanagement.com/nutrition-exercise/exercise/considerations-exercising-type-1-diabetes/'});">Considerations for Exercising With Type 1 Diabetes</a></li><li><a href="https://www.diabetesselfmanagement.com/nutrition-exercise/exercise/yoga-therapy-diabetes/" onclick="dataLayer.push({'event':'GAevent','eventCategory': 'Related Articles', 'eventAction': 'Click-Desktop', 'eventLabel':'https://www.diabetesselfmanagement.com/nutrition-exercise/exercise/yoga-therapy-diabetes/'});">Yoga Therapy for Diabetes</a></li><li><a href="https://www.diabetesselfmanagement.com/nutrition-exercise/exercise/diabetes-kickboxing/" onclick="dataLayer.push({'event':'GAevent','eventCategory': 'Related Articles', 'eventAction': 'Click-Desktop', 'eventLabel':'https://www.diabetesselfmanagement.com/nutrition-exercise/exercise/diabetes-kickboxing/'});">Diabetes and Kickboxing</a></li><li><a href="https://www.diabetesselfmanagement.com/nutrition-exercise/exercise/home-gym-budget/" onclick="dataLayer.push({'event':'GAevent','eventCategory': 'Related Articles', 'eventAction': 'Click-Desktop', 'eventLabel':'https://www.diabetesselfmanagement.com/nutrition-exercise/exercise/home-gym-budget/'});">Home Gym on a Budget</a></li></ul><p><a class="btn btn--a" href="https://www.diabetesselfmanagement.com/nutrition-exercise/exercise/">More Exercise Articles</a></p></div></div></div></div></div><div class="col-wrap clearfix"><div class="col palm-one-whole lap-one-half desk-one-whole"><div class="widget widget--ad widget--ad-2 txt-c"><div class="ad--box"><div class="txt-c ad__heading"><small>Advertisement</small></div><div id="div-ad-boxb"> <script type="text/javascript">googletag.display('div-ad-boxb');</script> </div></div></div></div><div class="col palm-one-whole lap-one-half desk-one-whole"><div class="widget"><h3 class="widget-title">Featured Recipe</h3><div class="widget-content"><article id="post-30625"><div class="featured-image"> <a href="https://www.diabetesselfmanagement.com/recipes/beverages/spiced-citrus-tea/" rel="bookmark"> <noscript><img width="300" height="200" src="https://cdn.diabetesselfmanagement.com/2017/11/Spiced-Citrus-Tea-300x200.jpg" class="attachment-medium size-medium wp-post-image" alt="Spiced Citrus Tea" title="Spiced Citrus Tea" srcset="//cdn.diabetesselfmanagement.com/2017/11/Spiced-Citrus-Tea-300x200.jpg 300w, //cdn.diabetesselfmanagement.com/2017/11/Spiced-Citrus-Tea-768x512.jpg 768w, //cdn.diabetesselfmanagement.com/2017/11/Spiced-Citrus-Tea.jpg 1000w" sizes="(max-width: 300px) 100vw, 300px" /></noscript><img width="300" height="200" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20300%20200%22%3E%3C/svg%3E' data-src="https://cdn.diabetesselfmanagement.com/2017/11/Spiced-Citrus-Tea-300x200.jpg" class="lazyload attachment-medium size-medium wp-post-image" alt="Spiced Citrus Tea" title="Spiced Citrus Tea" data-srcset="//cdn.diabetesselfmanagement.com/2017/11/Spiced-Citrus-Tea-300x200.jpg 300w, //cdn.diabetesselfmanagement.com/2017/11/Spiced-Citrus-Tea-768x512.jpg 768w, //cdn.diabetesselfmanagement.com/2017/11/Spiced-Citrus-Tea.jpg 1000w" data-sizes="(max-width: 300px) 100vw, 300px" /> </a></div><header class="entry-header"><h3 class="entry-title"><a href="https://www.diabetesselfmanagement.com/recipes/beverages/spiced-citrus-tea/" rel="bookmark">Spiced Citrus Tea</a></h3></header><div class="entry-footer"> <a class="btn btn--a" href="https://www.diabetesselfmanagement.com/recipes/">More Diabetes Recipes</a></div></article></div></div></div></div><div class="col-wrap clearfix"><div class="col palm-one-whole lap-one-half desk-one-whole"><div class="widget widget--ad widget--ad-3 txt-c"><div class="ad ad--box"><div class="txt-c ad__heading"><small>Advertisement</small></div><div id="div-ad-boxc"> <script type="text/javascript">googletag.display('div-ad-boxc');</script> </div></div></div></div><div class="col palm-one-whole lap-one-half desk-one-whole"><div class="widget widget--recent-articles"><h3 class="widget-title">Editor's Picks</h3><div class="widget-content"><ul class="ul-divided"><li><a href="https://www.diabetesselfmanagement.com/blog/what-is-a-normal-blood-sugar-level/" class="ga_tracker_EditorsPicks">What Is a Normal Blood Sugar Level? </a></li><li><a href="https://www.diabetesselfmanagement.com/managing-diabetes/treatment-approaches/metformin-2/" class="ga_tracker_EditorsPicks">Metformin:<br />The Unauthorized Biography </a></li><li><a href="https://www.diabetesselfmanagement.com/managing-diabetes/blood-glucose-management/manage-high-blood-glucose/" class="ga_tracker_EditorsPicks">Strike the Spike II: How to Manage High Blood Glucose After Meals:<br />Dealing With High Blood Sugar After Meals </a></li><li><a href="https://www.diabetesselfmanagement.com/blog/what-causes-diabetes-fatigue/" class="ga_tracker_EditorsPicks">What Causes Diabetes Fatigue? </a></li><li><a href="https://www.diabetesselfmanagement.com/blog/bitter-melon-diabetes-news/" class="ga_tracker_EditorsPicks">Bitter Melon Diabetes News </a></li></ul></div></div></div></div><div class="col-wrap clearfix"><div class="col palm-one-whole lap-one-half desk-one-whole"><div class="widget widget--ad widget--ad-4 txt-c"><div class="ad ad--box"><div class="txt-c ad__heading"><small>Advertisement</small></div><div id="div-ad-boxd"> <script type="text/javascript">googletag.display('div-ad-boxd');</script> </div></div></div></div><div class="col palm-one-whole lap-one-half desk-one-whole"><div class="widget widget-newsletter"><div class="newsletter txt-c"> <a href="/newsletter/"><noscript><img src="https://www.diabetesselfmanagement.com/wp-content/themes/dsmrefresh/images/newsletter.png" alt"Subscribe to Diabetes Self-Management Newsletter" width="66" height="67" ></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2066%2067%22%3E%3C/svg%3E' data-src="https://www.diabetesselfmanagement.com/wp-content/themes/dsmrefresh/images/newsletter.png" alt"Subscribe to Diabetes Self-Management Newsletter" width="66" height="67" ></a><h3 class="newsletter__heading">Sign-up for the Diabetes Self-Management Newsletter</h3> <a class="btn btn-alt" href="/newsletter/">&nbsp;&nbsp;Sign up for Free!&nbsp;&nbsp;</a></div></div></div><div class="col palm-one-whole lap-one-half desk-one-whole"><div class="widget widget-poll"><h3 class="widget-title upper widget-poll__heading">Readers' Poll</h3><div class="widget-content widget-poll__content"><div id="polls-2" class="wp-polls"><form id="polls_form_2" class="wp-polls-form" action="/index.php" method="post"><p style="display: none;"><input type="hidden" id="poll_2_nonce" name="wp-polls-nonce" value="f51296ede5" /></p><p style="display: none;"><input type="hidden" name="poll_id" value="2" /></p><p style="display: none;"><input type="hidden" id="poll_multiple_ans_2" name="poll_multiple_ans_2" value="6" /></p><p class="poll__question"><strong>What do you want to read about?</strong></p><div id="polls-2-ans" class="wp-polls-ans"><ul class="wp-polls-ul"><li><input type="checkbox" id="poll-answer-6" name="poll_2" value="6" /> <label for="poll-answer-6">Medication</label></li><li><input type="checkbox" id="poll-answer-7" name="poll_2" value="7" /> <label for="poll-answer-7">Exercise</label></li><li><input type="checkbox" id="poll-answer-8" name="poll_2" value="8" /> <label for="poll-answer-8">Nutrition</label></li><li><input type="checkbox" id="poll-answer-9" name="poll_2" value="9" /> <label for="poll-answer-9">News</label></li><li><input type="checkbox" id="poll-answer-10" name="poll_2" value="10" /> <label for="poll-answer-10">Recipes</label></li><li><input type="checkbox" id="poll-answer-11" name="poll_2" value="11" /> <label for="poll-answer-11">Diabetes complications</label></li></ul><p class="poll__action"><input class="wp-polls-btn" type="button" name="vote" value="   Vote   " onclick="poll_vote(2);" />&nbsp;&nbsp;&nbsp;<a href="#ViewPollResults" onclick="poll_result(2); return false;" title="View Results Of This Poll">View Results</a></p></div></form></div><div id="polls-2-loading" class="wp-polls-loading"><noscript><img src="https://www.diabetesselfmanagement.com/wp-content/plugins/wp-polls/images/loading.gif" width="16" height="16" alt="Loading ..." title="Loading ..." class="wp-polls-image" /></noscript><img src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2016%2016%22%3E%3C/svg%3E' data-src="https://www.diabetesselfmanagement.com/wp-content/plugins/wp-polls/images/loading.gif" width="16" height="16" alt="Loading ..." title="Loading ..." class="lazyload wp-polls-image" />&nbsp;Loading ...</div></div></div></div></div></div><!-- #secondary --></div></div><!-- #content --><section id="foot-newsletter" role="contentinfo"><div class="wrapper" ><div class="clear"><div class="col txt-r news-img portable-one-whole desk-one-quarter"> <a href="/newsletter/"><noscript><img style="padding-top: 10px;" src="https://www.diabetesselfmanagement.com/wp-content/themes/dsmrefresh/images/newsletter.png" alt"Subscribe to Diabetes Self-Management Newsletter" width="66" height="67" ></noscript><img class="lazyload" style="padding-top: 10px;" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2066%2067%22%3E%3C/svg%3E' data-src="https://www.diabetesselfmanagement.com/wp-content/themes/dsmrefresh/images/newsletter.png" alt"Subscribe to Diabetes Self-Management Newsletter" width="66" height="67" ></a></div><div style="padding-left: 25px;" class="col newsletter-info portable-one-whole desk-two-fifths" role="complementary">Get the latest diabetes news and a free gift!</div><div style="padding: 20px;" class="col portable-one-whole desk-one-third"><a class="btn btn-alt" href="/newsletter/">Sign up for Free!</a></div></div></div></section><footer id="colophon" class="site-footer" role="contentinfo"><div class="wrapper" ><div class="clear"><div class="site-footer__subscribe"> <a href="/subscribe/"><noscript><img src="https://www.diabetesselfmanagement.com/wp-content/themes/dsmrefresh/images/subscribe.png" alt"Subscribe to Diabetes Self-Management"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20%20%22%3E%3C/svg%3E' data-src="https://www.diabetesselfmanagement.com/wp-content/themes/dsmrefresh/images/subscribe.png" alt"Subscribe to Diabetes Self-Management"></a></div><!-- .site-footer__branding --><div class="site-footer__subtext"><h3 class="site-footer__heading">Subscribe</h3><p><em>Diabetes Self-Management</em> offers up-to-date, practical “how-to” information on nutrition, exercise, new drugs, medical advances, self-help, and the many other topics people need to know about to stay healthy.</p> <a class="btn btn--a" href="/subscribe/">Subscribe</a></div><div class="site-footer__site-map"><h3 class="site-footer__heading">Additional Links</h3><div class="menu-secondary-container"><ul id="menu-secondary" class="menu"><li id="menu-item-85" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-85"> <a href="https://www.diabetesselfmanagement.com/subscribe/">Subscribe to Diabetes Self-Management Magazine</a></li><li id="menu-item-86" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-86"> <a href="https://www.diabetesselfmanagement.com/about-us/">About Us</a></li><li id="menu-item-87" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87"> <a href="https://www.diabetesselfmanagement.com/contact/">Contact</a></li><li id="menu-item-10069" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10069"> <a href="https://www.diabetesselfmanagement.com/newsletter/">Diabetes Self-Management  Newsletter</a></li><li id="menu-item-88" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-88"> <a href="https://www.diabetesselfmanagement.com/advertise/">Advertise</a></li><li id="menu-item-35849" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-35849"> <a href="https://www.diabetesselfmanagement.com/about-our-expert-authors/">About Our Authors</a></li><li id="menu-item-89" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-89"> <a href="https://www.diabetesselfmanagement.com/privacy-policy/">Privacy Policy</a></li><li id="menu-item-10072" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10072"> <a href="https://www.diabetesselfmanagement.com/terms-use/">Terms of Use</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page"><a class="cli_manage_current_consent" style="cursor:pointer;"> Manage Your Consent</a></li></ul></div></div><!-- .site-footer__site-map --></div><div class="site-footer__legal"></div><!-- .site-info --></div> <br />&nbsp;<br />&nbsp;<br /></footer><!-- #colophon --><footer id="colophon" class="site-anchor" role="contentinfo"><div class="wrapper" ><div class="clear"><div class="site-footer__branding"> <a href="https://www.diabetesselfmanagement.com/" rel="home"><noscript><img alt="Diabetes Self-Management" src="https://www.diabetesselfmanagement.com/wp-content/themes/dsmrefresh/images/logo-footer.png" width="150" /></noscript><img class="lazyload" alt="Diabetes Self-Management" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20150%20%22%3E%3C/svg%3E' data-src="https://www.diabetesselfmanagement.com/wp-content/themes/dsmrefresh/images/logo-footer.png" width="150" /></a></div><!-- .site-footer__branding --><div class="site-footer__social"><ul class="social-nav"><li class="social-nav__item social-nav__facebook"><a class="icon icon-facebook-circled" href="https://www.facebook.com/DiabetesSelfManagement" target="_blank"><span class="screen-reader-text">Facebook</span></a></li><li class="social-nav__item social-nav__twitter"><a class="icon icon-twitter-circled" href="https://twitter.com/ManageDiabetes" target="_blank"><span class="screen-reader-text">Twitter</span></a></li><li class="social-nav__item social-nav__pinterest"><a class="icon icon-pinterest" href="https://www.pinterest.com/diabetesrecipes/" target="_blank"><span class="screen-reader-text">Pinterest</span></a></li></ul></div><!-- .site-footer__social --><div class="copyright"><p><a href="https://www.healthonnet.org/HONcode/Conduct.html?HONConduct248569" onclick="window.open(this.href); return false;"><noscript><img src="https://www.honcode.ch/HONcode/Seal/HONConduct248569_s.gif" width="49" height="72" style="border:0px;padding-right:20px;vertical-align:middle;" title="This website is certified by Health On the Net Foundation. Click to verify." alt="This website is certified by Health On the Net Foundation. Click to verify."></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2049%2072%22%3E%3C/svg%3E' data-src="https://www.honcode.ch/HONcode/Seal/HONConduct248569_s.gif" width="49" height="72" style="border:0px;padding-right:20px;vertical-align:middle;" title="This website is certified by Health On the Net Foundation. Click to verify." alt="This website is certified by Health On the Net Foundation. Click to verify."></a>&copy; 2020 Madavor Media, LLC. All Rights Reserved.</p></div><!-- .copyright --></div></div></footer></div><!-- #page --> <!-- ngg_resource_manager_marker --><script type='text/javascript' data-cfasync="false" async defer='defer' src='//widgets.getsitecontrol.com/52448/script.js?ver=3.0.0'></script>
<script type='text/javascript' defer='defer' src='https://www.diabetesselfmanagement.com/wp-content/plugins/jquery-collapse-o-matic/js/collapse.js?ver=1.6.18'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"https:\/\/www.diabetesselfmanagement.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' defer='defer' src='https://www.diabetesselfmanagement.com/wp-content/plugins/wp-polls/polls-js.js?ver=2.75.3'></script>
<script type='text/javascript' defer='defer' src='https://www.diabetesselfmanagement.com/wp-content/themes/dsmrefresh/js/global-min.js?ver=20159197'></script>
<script type='text/javascript' defer='defer' src='https://www.diabetesselfmanagement.com/wp-includes/js/comment-reply.min.js?ver=ba455dc74f620980177cc6e04271a0cd'></script>
<script type='text/javascript' defer='defer' src='https://www.diabetesselfmanagement.com/wp-includes/js/wp-embed.min.js?ver=ba455dc74f620980177cc6e04271a0cd'></script>
<div id="amzn-assoc-ad-58e18ae4-08d1-46b0-8c26-ecd6a1a36e99"></div><script async src="//z-na.amazon-adsystem.com/widgets/onejs?MarketPlace=US&adInstanceId=58e18ae4-08d1-46b0-8c26-ecd6a1a36e99"></script><div id="cookie-law-info-bar"><span><span class="cli-plugin-button-mobile"><a  data-cli_action="accept" id="cookie_action_close_header"  class="medium cli-plugin-button cli-plugin-main-button cookie_action_close_header cli_action_button" style="display:inline-block;  margin:5px; ">ACCEPT</a> <a  id="cookie_action_close_header_reject"  class="medium cli-plugin-button cli-plugin-main-button cookie_action_close_header_reject cli_action_button"  data-cli_action="reject" style="margin:5px;" >REJECT</a></span><a href='https://www.diabetesselfmanagement.com/privacy-policy/' id="CONSTANT_OPEN_URL" target="_blank"  class="cli-plugin-main-link"  style="display:inline-block; margin:5px; " >Privacy Policy</a> We use <a class="cli_settings_button"  >cookies</a> on our site to personalize content and ads, provide social media features, and analyze our traffic.</span></div><div id="cookie-law-info-again" style="display:none;"><span id="cookie_hdr_showagain">Privacy & Cookies Policy</span></div><div class="cli-modal" id="cliSettingsPopup" tabindex="-1" role="dialog" aria-labelledby="cliSettingsPopup" aria-hidden="true"><div class="cli-modal-dialog" role="document"><div class="cli-modal-content cli-bar-popup"> <button type="button" class="cli-modal-close" id="cliModalClose"> <svg class="" viewBox="0 0 24 24"><path d="M19 6.41l-1.41-1.41-5.59 5.59-5.59-5.59-1.41 1.41 5.59 5.59-5.59 5.59 1.41 1.41 5.59-5.59 5.59 5.59 1.41-1.41-5.59-5.59z"></path><path d="M0 0h24v24h-24z" fill="none"></path></svg> </button><div class="cli-modal-body"><div class="cli-container-fluid cli-tab-container"><div class="cli-row"><div class="cli-col-12 cli-align-items-stretch cli-px-0"><div class="cli-privacy-overview"><h4>Privacy Overview</h4><div class="cli-privacy-content"><div class="cli-privacy-content-text">This website uses cookies to improve your experience while you navigate through the website. Out of these cookies, the cookies that are categorized as necessary are stored on your browser as they are as essential for the working of basic functionalities of the website. We also use third-party cookies that help us analyze and understand how you use this website. These cookies will be stored in your browser only with your consent. You also have the option to opt-out of these cookies. But opting out of some of these cookies may have an effect on your browsing experience.</div></div> <a class="cli-privacy-readmore" data-readmore-text="Show more" data-readless-text="Show less"></a></div></div><div class="cli-col-12 cli-align-items-stretch cli-px-0 cli-tab-section-container"><div class="cli-tab-section cli-privacy-tab"><div class="cli-tab-header"> <a class="cli-nav-link cli-settings-mobile" > Privacy Overview </a></div><div class="cli-tab-content"><div class="cli-tab-pane cli-fade"><p>This website uses cookies to improve your experience while you navigate through the website. Out of these cookies, the cookies that are categorized as necessary are stored on your browser as they are as essential for the working of basic functionalities of the website. We also use third-party cookies that help us analyze and understand how you use this website. These cookies will be stored in your browser only with your consent. You also have the option to opt-out of these cookies. But opting out of some of these cookies may have an effect on your browsing experience.</p></div></div></div><div class="cli-tab-section"><div class="cli-tab-header"> <a class="cli-nav-link cli-settings-mobile" data-target="necessary" data-toggle="cli-toggle-tab" > Necessary </a> <span class="cli-necessary-caption">Always Enabled</span></div><div class="cli-tab-content"><div class="cli-tab-pane cli-fade" data-id="necessary"><p>Necessary cookies are absolutely essential for the website to function properly. This category only includes cookies that ensures basic functionalities and security features of the website. These cookies do not store any personal information.</p></div></div></div></div></div></div></div></div></div></div><div class="cli-modal-backdrop cli-fade cli-settings-overlay"></div><div class="cli-modal-backdrop cli-fade cli-popupbar-overlay"></div> <script type="text/javascript">/* <![CDATA[ */
  cli_cookiebar_settings='{"animate_speed_hide":"500","animate_speed_show":"500","background":"#2a2a2a","border":"#b1a6a6c2","border_on":false,"button_1_button_colour":"#3dbfd7","button_1_button_hover":"#3199ac","button_1_link_colour":"#ffffff","button_1_as_button":true,"button_1_new_win":false,"button_2_button_colour":"#333","button_2_button_hover":"#292929","button_2_link_colour":"#ffffff","button_2_as_button":false,"button_2_hidebar":false,"button_3_button_colour":"#efefef","button_3_button_hover":"#bfbfbf","button_3_link_colour":"#0a0a0a","button_3_as_button":true,"button_3_new_win":false,"button_4_button_colour":"#e5e5e5","button_4_button_hover":"#b7b7b7","button_4_link_colour":"#ffffff","button_4_as_button":false,"font_family":"inherit","header_fix":false,"notify_animate_hide":true,"notify_animate_show":false,"notify_div_id":"#cookie-law-info-bar","notify_position_horizontal":"right","notify_position_vertical":"bottom","scroll_close":false,"scroll_close_reload":false,"accept_close_reload":false,"reject_close_reload":false,"showagain_tab":false,"showagain_background":"#fff","showagain_border":"#000","showagain_div_id":"#cookie-law-info-again","showagain_x_position":"100px","text":"#8a8a8a","show_once_yn":false,"show_once":"10000","logging_on":false,"as_popup":false,"popup_overlay":true,"bar_heading_text":"","cookie_bar_as":"banner","popup_showagain_position":"bottom-right","widget_position":"left"}';
  /* ]]> */</script><script type='text/javascript'>var colomatduration = 'fast';
var colomatslideEffect = 'slideToggle';
var colomatpauseInit = '';
var colomattouchstart = '';</script> <noscript><style>.lazyload{display:none;}</style></noscript><script data-noptimize="1">window.lazySizesConfig=window.lazySizesConfig||{};window.lazySizesConfig.loadMode=1;</script><script async data-noptimize="1" src='https://www.diabetesselfmanagement.com/wp-content/plugins/autoptimize/classes/external/js/lazysizes.min.js'></script> <script type="text/javascript">jQuery(document).ready(function(){
	        jQuery('.cli_manage_current_consent').click(function(){
	            jQuery('#cookie-law-info-again').click();
	            setTimeout(function(){
	                jQuery(window).scrollTop(jQuery('#cookie-law-info-bar').offset().top);
	            },1000);
	        });
	    });</script> <div id="interstitial"> <script type='text/javascript'>googletag.display('interstitial');</script> </div><div id="div-oop"> <script type='text/javascript'>googletag.display('div-oop');</script> </div> <script type="text/javascript"  defer='defer' src="https://www.diabetesselfmanagement.com/wp-content/cache/autoptimize/js/autoptimize_e54369f70ce2d24b5590b6f8b31b58f7.js"></script></body></html>